Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "A simple shell script to run all installed ptests" |
| 2 | DESCRIPTION = "The ptest-runner package installs a ptest-runner \ |
| 3 | shell script which loops through all installed ptest test suites and \ |
| 4 | runs them in sequence." |
| 5 | HOMEPAGE = "https://wiki.yoctoproject.org/wiki/Ptest" |
| 6 | SRC_URI += "file://ptest-runner" |
| 7 | |
| 8 | LICENSE = "MIT" |
| 9 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \ |
| 10 | file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
| 11 | |
| 12 | INHIBIT_DEFAULT_DEPS = "1" |
| 13 | |
| 14 | S = "${WORKDIR}" |
| 15 | |
| 16 | do_install () { |
| 17 | mkdir -p ${D}${bindir} |
| 18 | install -m 0755 ${WORKDIR}/ptest-runner ${D}${bindir} |
| 19 | } |
| 20 | |
| 21 | do_patch[noexec] = "1" |
| 22 | do_configure[noexec] = "1" |
| 23 | do_compile[noexec] = "1" |
| 24 | do_build[noexec] = "1" |