Andrew Geissler | 3e34fba | 2021-03-05 15:21:55 -0600 | [diff] [blame] | 1 | SUMMARY = "CircuitPython helper library for DC & Stepper Motor FeatherWing, Shield, and Pi Hat kits." |
| 2 | HOMEPAGE = "https://github.com/adafruit/Adafruit_CircuitPython_MotorKit" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=6ad4a8854b39ad474755ef1aea813bac" |
| 5 | |
| 6 | SRC_URI = "git://github.com/adafruit/Adafruit_CircuitPython_MotorKit.git" |
| 7 | SRCREV = "8c1462b4129b21f6db156d1517abb017bb74b982" |
| 8 | |
| 9 | S = "${WORKDIR}/git" |
| 10 | |
| 11 | inherit setuptools3 |
| 12 | |
| 13 | DEPENDS += "python3-setuptools-scm-native" |
| 14 | |
| 15 | RDEPENDS_${PN} += " \ |
| 16 | python3-adafruit-blinka \ |
| 17 | python3-adafruit-circuitpython-busdevice \ |
| 18 | python3-adafruit-circuitpython-motor \ |
| 19 | python3-adafruit-circuitpython-pca9685 \ |
| 20 | python3-adafruit-circuitpython-register \ |
| 21 | python3-core \ |
| 22 | " |