Andrew Geissler | 3e34fba | 2021-03-05 15:21:55 -0600 | [diff] [blame] | 1 | SUMMARY = "Pure python (i.e. no native extensions) access to Linux IO including I2C and SPI. Drop in replacement for smbus and spidev modules." |
| 2 | HOMEPAGE = "https://github.com/adafruit/Adafruit_Python_PureIO" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2a21fcca821a506d4c36f7bbecc0d009" |
| 5 | |
| 6 | SRC_URI = "git://github.com/adafruit/Adafruit_Python_PureIO.git" |
| 7 | SRCREV = "f4d0973da05b8b21905ff6bab69cdb652128f342" |
| 8 | |
| 9 | S = "${WORKDIR}/git" |
| 10 | |
| 11 | inherit setuptools3 |
| 12 | |
| 13 | DEPENDS += "python3-setuptools-scm-native" |
| 14 | |
| 15 | RDEPENDS_${PN} += " \ |
| 16 | python3-core \ |
| 17 | python3-ctypes \ |
| 18 | python3-fcntl \ |
| 19 | " |