Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Implements a XML/HTML/XHTML Markup safe string for Python" |
| 2 | HOMEPAGE = "http://github.com/mitsuhiko/markupsafe" |
| 3 | LICENSE = "BSD-3-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75" |
| 5 | |
| 6 | SRC_URI[md5sum] = "43fd756864fe42063068e092e220c57b" |
| 7 | SRC_URI[sha256sum] = "29872e92839765e546828bb7754a68c418d927cd064fd4708fab9fe9c8bb116b" |
| 8 | |
| 9 | PYPI_PACKAGE = "MarkupSafe" |
| 10 | inherit pypi ptest setuptools3 |
| 11 | |
| 12 | RDEPENDS_${PN} += "${PYTHON_PN}-stringold" |
| 13 | |
| 14 | BBCLASSEXTEND = "native nativesdk" |
| 15 | |
| 16 | SRC_URI += " \ |
| 17 | file://run-ptest \ |
| 18 | " |
| 19 | |
| 20 | RDEPENDS_${PN}-ptest += " \ |
| 21 | ${PYTHON_PN}-pytest \ |
| 22 | " |
| 23 | |
| 24 | do_install_ptest() { |
| 25 | install -d ${D}${PTEST_PATH}/tests |
| 26 | cp -f ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 27 | } |