Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Debugging and profiling extension for PHP" |
| 2 | LICENSE = "Xdebug" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=34df3a274aa12b795417c65634c07f16" |
| 4 | |
| 5 | DEPENDS = "php re2c-native" |
| 6 | |
| 7 | SRC_URI = "http://xdebug.org/files/xdebug-${PV}.tgz" |
| 8 | |
| 9 | SRC_URI[md5sum] = "ed3545852e6f4a00fb8730362d0431ee" |
| 10 | SRC_URI[sha256sum] = "b5264cc03bf68fcbb04b97229f96dca505d7b87ec2fb3bd4249896783d29cbdc" |
| 11 | |
| 12 | inherit autotools |
| 13 | |
| 14 | EXTRA_OECONF += "--enable-xdebug -with-php-config=${STAGING_BINDIR_CROSS}/php-config" |
| 15 | |
| 16 | do_configure() { |
| 17 | cd ${S} |
| 18 | ${STAGING_BINDIR_CROSS}/phpize |
| 19 | cd ${B} |
| 20 | |
| 21 | # Running autoreconf as autotools_do_configure would do here |
| 22 | # breaks the libtool configuration resulting in a failure later |
| 23 | # in do_compile. It's possible this may be fixable, however the |
| 24 | # easiest course of action for the moment is to avoid doing that. |
| 25 | oe_runconf |
| 26 | } |
| 27 | |
| 28 | do_install() { |
| 29 | oe_runmake install INSTALL_ROOT=${D} |
| 30 | } |
| 31 | |
| 32 | FILES_${PN} += "${libdir}/php*/extensions/*/*.so" |
| 33 | FILES_${PN}-dbg += "${libdir}/php*/extensions/*/.debug" |