blob: 8a8a48467d12183b1f1b89312de70d00ad6f3d2d [file] [log] [blame]
Patrick Williams03514f12024-04-05 07:04:11 -05001DESCRIPTION = "Tomli-W is a Python library for writing TOML. It is a write-only counterpart to Tomli, which is a read-only TOML parser."
2HOMEPAGE = "https://github.com/hukkin/tomli-w"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=aaaaf0879d17df0110d1aa8c8c9f46f5"
5
6SRCREV = "19099125f32e7c491603e393263754262b356956"
7PYPI_SRC_URI = "git://github.com/hukkin/tomli-w.git;protocol=https;branch=master"
8
9inherit pypi python_flit_core ptest
10
11S = "${WORKDIR}/git"
12
13SRC_URI += " \
14 file://run-ptest \
15"
16
17RDEPENDS:${PN}-ptest += " \
18 python3-pytest \
19 python3-tomli \
20 python3-unittest-automake-output \
21"
22
23do_install_ptest() {
24 install -d ${D}${PTEST_PATH}/tests
25 install -d ${D}${PTEST_PATH}/benchmark
26 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
27 cp -rf ${S}/benchmark/* ${D}${PTEST_PATH}/benchmark/
28}
29
30RDEPENDS:${PN} += " \
31 python3-datetime \
32 python3-numbers \
33 python3-stringold \
34"