blob: da672001eef64ef19fd9d2ecc3bb2cefefd8988b [file] [log] [blame]
George Hungf089ba12020-05-20 17:22:25 +08001PR = "r1"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
4
George Hungf089ba12020-05-20 17:22:25 +08005inherit systemd
6inherit obmc-phosphor-systemd
7
George Hungf089ba12020-05-20 17:22:25 +08008SRC_URI = " file://phosphor-ipmi-flash-bmc-verify.service \
9 file://bmc-verify.sh \
10 file://config-bmc.json \
11 "
12
13FILES_${PN} += "${datadir}/phosphor-ipmi-flash/config-bmc.json"
14
Brandon Kimcf406822021-07-30 16:19:14 -070015PROVIDES += "virtual/bmc-update"
16RPROVIDES_${PN} += "virtual/bmc-update"
17
George Hungf089ba12020-05-20 17:22:25 +080018DEPENDS += "systemd"
19DEPENDS += "phosphor-ipmi-flash"
20RDEPENDS_${PN} = "bash"
21
22do_install() {
23 install -d ${D}${bindir}
24 install -m 0755 ${WORKDIR}/bmc-verify.sh ${D}${bindir}/
25
26 install -d ${D}${systemd_system_unitdir}
27 install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-bmc-verify.service ${D}${systemd_system_unitdir}
28
29 install -d ${D}${datadir}/phosphor-ipmi-flash
30 install -m 0644 ${WORKDIR}/config-bmc.json ${D}${datadir}/phosphor-ipmi-flash
31}
32
33
34SYSTEMD_PACKAGES = "${PN}"
35SYSTEMD_SERVICE_${PN} = "phosphor-ipmi-flash-bmc-verify.service"