Naveen Moses | c8d90aa | 2021-10-07 18:20:33 +0530 | [diff] [blame] | 1 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" |
| 2 | |
Patrick Williams | d5c716d | 2022-02-17 07:30:57 -0600 | [diff] [blame] | 3 | SRC_URI:append:fb-withhost = " file://set-bmc-time-from-host" |
Naveen Moses | c8d90aa | 2021-10-07 18:20:33 +0530 | [diff] [blame] | 4 | |
| 5 | |
Patrick Williams | d5c716d | 2022-02-17 07:30:57 -0600 | [diff] [blame] | 6 | RDEPENDS:${PN}:append:fb-withhost = " bash" |
Naveen Moses | c8d90aa | 2021-10-07 18:20:33 +0530 | [diff] [blame] | 7 | |
| 8 | do_install:append:fb-withhost(){ |
| 9 | |
| 10 | # Store the bitbake variable OBMC_HOST_INSTANCES inside time sync script as HOST_INSTANCES variable using sed. |
| 11 | sed -i -e "s,HOST_INSTANCES_SED_REPLACEMENT_VALUE,${OBMC_HOST_INSTANCES},g" ${WORKDIR}/set-bmc-time-from-host |
| 12 | |
| 13 | install -d ${D}$/lib/systemd/system |
| 14 | install -m 0644 ${WORKDIR}/bmc-set-time.service ${D}$/lib/systemd/system |
Patrick Williams | edf8fe5 | 2023-03-24 09:46:00 -0500 | [diff] [blame] | 15 | install -d ${D}${libexecdir} |
| 16 | install -m 0777 ${WORKDIR}/set-bmc-time-from-host ${D}${libexecdir} |
Naveen Moses | c8d90aa | 2021-10-07 18:20:33 +0530 | [diff] [blame] | 17 | } |
| 18 | |
| 19 | SYSTEMD_SERVICE:${PN}:fb-withhost += "bmc-set-time.service" |