Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "XFS Filesystem Utilities" |
| 2 | HOMEPAGE = "http://oss.sgi.com/projects/xfs" |
| 3 | SECTION = "base" |
| 4 | LICENSE = "GPLv2 & LGPLv2.1" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 5 | LICENSE:libhandle = "LGPLv2.1" |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://LICENSES/GPL-2.0;md5=e6a75371ba4d16749254a51215d13f97 \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 7 | file://LICENSES/LGPL-2.1;md5=b370887980db5dd40659b50909238dbd" |
| 8 | DEPENDS = "util-linux util-linux-native" |
| 9 | SRC_URI = "https://www.kernel.org/pub/linux/utils/fs/xfs/xfsprogs/${BP}.tar.xz \ |
| 10 | file://remove_flags_from_build_flags.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 11 | file://0001-Check-for-MAP_SYNC-in-sys-mman.h.patch \ |
| 12 | file://0002-include-include-xfs-linux.h-after-sys-mman.h.patch \ |
Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 13 | file://0001-support-usrmerge.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 14 | " |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "4e142d4babe086adf9016d8c606c805829da08e46389a4433f40346204f90cdb" |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 16 | inherit autotools-brokensep pkgconfig |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 17 | |
| 18 | PACKAGES =+ "${PN}-fsck ${PN}-mkfs ${PN}-repair libhandle" |
| 19 | |
Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame] | 20 | DEPENDS += "util-linux libinih" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 21 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 22 | RDEPENDS:${PN} = "${PN}-fsck ${PN}-mkfs ${PN}-repair" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 23 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 24 | FILES:${PN}-fsck = "${base_sbindir}/fsck.xfs" |
| 25 | FILES:${PN}-mkfs = "${base_sbindir}/mkfs.xfs" |
| 26 | FILES:${PN}-repair = "${base_sbindir}/xfs_repair" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 27 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 28 | FILES:libhandle = "${base_libdir}/libhandle${SOLIBS}" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 29 | |
| 30 | EXTRA_OECONF = "--enable-gettext=no \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 31 | --enable-scrub=no \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 32 | INSTALL_USER=root \ |
| 33 | INSTALL_GROUP=root \ |
| 34 | ac_cv_header_aio_h=yes \ |
| 35 | ac_cv_lib_rt_lio_listio=yes \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 36 | OPTIMIZER='${SELECTED_OPTIMIZATION}' \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 37 | " |
| 38 | |
| 39 | DISABLE_STATIC = "" |
| 40 | EXTRA_AUTORECONF += "-I ${S}/m4 --exclude=autoheader" |
| 41 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 42 | PACKAGECONFIG ??= "blkid" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 43 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 44 | PACKAGECONFIG[blkid] = "--enable-blkid=yes,--enable-blkid=no,util-linux" |
| 45 | |
| 46 | export DEBUG="-DNDEBUG" |
| 47 | export BUILD_VERBOSE="1" |
| 48 | export tagname="CC" |
| 49 | |
| 50 | EXTRA_OEMAKE = "DIST_ROOT='${D}'" |
| 51 | |
| 52 | do_configure () { |
| 53 | export BUILD_CC="${BUILD_CC} ${BUILD_CFLAGS}" |
| 54 | # Prevent Makefile from calling configure without arguments, |
| 55 | # when do_configure gets called for a second time. |
| 56 | rm -f ${B}/include/builddefs ${B}/include/platform_defs.h ${B}/configure |
| 57 | # Recreate configure script. |
| 58 | oe_runmake configure |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 59 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S} |
| 60 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S} |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 61 | oe_runconf |
| 62 | } |
| 63 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 64 | do_install:append() { |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 65 | oe_runmake 'DESTDIR=${D}' install-dev |
| 66 | rm ${D}${libdir}/*.la |
| 67 | rmdir --ignore-fail-on-non-empty ${D}${libdir} |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 68 | |
Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 69 | if [ ${libdir} != ${base_libdir} ];then |
| 70 | ln -sf -r ${D}${libdir}/libhandle.a ${D}${base_libdir}/libhandle.a |
| 71 | ln -sf -r ${D}${base_libdir}/libhandle.so ${D}${libdir}/libhandle.so |
| 72 | fi |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 73 | } |