Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 1 | SUMMARY = "System performance benchmark" |
| 2 | HOMEPAGE = "http://github.com/akopytov/sysbench" |
| 3 | SECTION = "console/tests" |
| 4 | LICENSE = "GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
| 6 | |
| 7 | inherit autotools |
| 8 | |
| 9 | # The project has moved from Sourceforge to Launchpad, to Github. Use the source tarball from |
| 10 | # Launchpad until the next release is available from Github. |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 11 | SRC_URI = "https://launchpad.net/ubuntu/+archive/primary/+files/${BPN}_${PV}.orig.tar.gz \ |
| 12 | file://0001-Adding-volatile-modifier-to-tmp-variable-in-memory-t.patch \ |
| 13 | " |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 14 | |
| 15 | SRC_URI[md5sum] = "3a6d54fdd3fe002328e4458206392b9d" |
| 16 | SRC_URI[sha256sum] = "83fa7464193e012c91254e595a89894d8e35b4a38324b52a5974777e3823ea9e" |
| 17 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 18 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)}" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 19 | PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,," |
| 20 | PACKAGECONFIG[aio] = "--enable-aio,--disable-aio,libaio," |
| 21 | PACKAGECONFIG[mysql] = "--with-mysql \ |
| 22 | --with-mysql-includes=${STAGING_INCDIR}/mysql \ |
| 23 | --with-mysql-libs=${STAGING_LIBDIR}, \ |
| 24 | --without-mysql,mysql5" |
| 25 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 26 | do_configure:prepend() { |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 27 | touch ${S}/NEWS ${S}/AUTHORS |
| 28 | } |