Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 1 | SUMMARY = "OpenMAX Integration layer for VCU" |
| 2 | DESCRIPTION = "OMX IL Libraries,test applications and headers for VCU" |
| 3 | LICENSE = "Proprietary" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=03a7aef7e6f6a76a59fd9b8ba450b493" |
| 5 | |
| 6 | XILINX_VCU_VERSION = "1.0.0" |
Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 7 | PV = "${XILINX_VCU_VERSION}-xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}" |
| 8 | |
Andrew Geissler | 7eb438a | 2020-11-30 19:53:16 -0600 | [diff] [blame] | 9 | BRANCH ?= "release-2020.2" |
Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 10 | REPO ?= "git://github.com/xilinx/vcu-omx-il.git;protocol=https" |
Andrew Geissler | 7eb438a | 2020-11-30 19:53:16 -0600 | [diff] [blame] | 11 | SRCREV ?= "4e9daf282a12ecba19fe12f296a31315f6a6bd2d" |
Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 12 | |
| 13 | BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}" |
| 14 | SRC_URI = "${REPO};${BRANCHARG}" |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | COMPATIBLE_MACHINE = "^$" |
| 19 | COMPATIBLE_MACHINE_zynqmp = "zynqmp" |
| 20 | |
Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 21 | PACKAGE_ARCH = "${SOC_FAMILY_ARCH}" |
Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 22 | |
| 23 | DEPENDS = "libvcu-xlnx" |
| 24 | RDEPENDS_${PN} = "kernel-module-vcu libvcu-xlnx" |
| 25 | |
| 26 | EXTERNAL_INCLUDE="${STAGING_INCDIR}/vcu-ctrl-sw/include" |
| 27 | |
| 28 | EXTRA_OEMAKE = " \ |
| 29 | CC='${CC}' CXX='${CXX} ${CXXFLAGS}' \ |
| 30 | EXTERNAL_INCLUDE='${EXTERNAL_INCLUDE}' \ |
| 31 | " |
| 32 | |
| 33 | do_install() { |
| 34 | install -d ${D}${libdir} |
| 35 | install -d ${D}${includedir}/vcu-omx-il |
| 36 | |
| 37 | install -m 0644 ${S}/omx_header/*.h ${D}${includedir}/vcu-omx-il |
| 38 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 39 | install -Dm 0755 ${S}/bin/omx_decoder ${D}/${bindir}/omx_decoder |
| 40 | install -Dm 0755 ${S}/bin/omx_encoder ${D}/${bindir}/omx_encoder |
Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 41 | |
| 42 | oe_libinstall -C ${S}/bin/ -so libOMX.allegro.core ${D}/${libdir}/ |
| 43 | oe_libinstall -C ${S}/bin/ -so libOMX.allegro.video_decoder ${D}/${libdir}/ |
| 44 | oe_libinstall -C ${S}/bin/ -so libOMX.allegro.video_encoder ${D}/${libdir}/ |
| 45 | } |
| 46 | |
| 47 | # These libraries shouldn't get installed in world builds unless something |
| 48 | # explicitly depends upon them. |
| 49 | |
| 50 | EXCLUDE_FROM_WORLD = "1" |