blob: de199ef18b686f3d64c17a7cb899c30514434110 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Python library used to interact with Git repositories"
2DESCRIPTION = "GitPython provides object model read and write access to \
3a git repository. Access repository information conveniently, alter the \
4index directly, handle remotes, or go down to low-level object database \
5access with big-files support."
6HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
7SECTION = "devel/python"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=5279a7ab369ba336989dcf2a107e5c8e"
10
11PYPI_PACKAGE = "GitPython"
12
13inherit pypi python_setuptools_build_meta
14
Patrick Williams56b44a92024-01-19 08:49:29 -060015SRC_URI[sha256sum] = "ed66e624884f76df22c8e16066d567aaa5a37d5b5fa19db2c6df6f7156db9048"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060016
17DEPENDS += " ${PYTHON_PN}-gitdb"
18
19RDEPENDS:${PN} += " \
20 ${PYTHON_PN}-datetime \
21 ${PYTHON_PN}-gitdb \
22 ${PYTHON_PN}-io \
23 ${PYTHON_PN}-logging \
24 ${PYTHON_PN}-math \
25 ${PYTHON_PN}-netclient \
26 ${PYTHON_PN}-stringold \
27 ${PYTHON_PN}-unittest \
28 ${PYTHON_PN}-unixadmin \
29 git \
30"
31
32BBCLASSEXTEND = "native nativesdk"