Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Canonical source for classifiers on PyPI (pypi.org)." |
| 2 | HOMEPAGE = "https://github.com/pypa/trove-classifiers" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 5 | |
Patrick Williams | 56b44a9 | 2024-01-19 08:49:29 -0600 | [diff] [blame] | 6 | SRC_URI[sha256sum] = "6e36caf430ff6485c4b57a4c6b364a13f6a898d16b9417c6c37467e59c14b05a" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 7 | |
| 8 | inherit pypi python_setuptools_build_meta ptest |
| 9 | |
| 10 | DEPENDS += " python3-calver-native" |
| 11 | |
| 12 | SRC_URI += " \ |
| 13 | file://run-ptest \ |
| 14 | " |
| 15 | |
| 16 | RDEPENDS:${PN}-ptest += " \ |
| 17 | ${PYTHON_PN}-pytest \ |
| 18 | ${PYTHON_PN}-unittest-automake-output \ |
| 19 | " |
| 20 | |
| 21 | do_install_ptest() { |
| 22 | install -d ${D}${PTEST_PATH}/tests |
| 23 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 24 | } |
| 25 | |
| 26 | BBCLASSEXTEND = "native nativesdk" |