blob: a7e3096c6a66f5134d73e02aa4ed51b269d89f90 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4HOMEPAGE = "https://lttng.org/"
5LICENSE = "LGPL-2.1-only & GPL-2.0-only & MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=0464cff101a009c403cd2ed65d01d4c4"
7
8inherit module
9
10include lttng-platforms.inc
11
Patrick Williams03907ee2022-05-01 06:28:52 -050012SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
Patrick Williamsda295312023-12-05 16:48:56 -060013 file://0001-fix-phys_proc_id-and-cpu_core_id-moved-in-linux-6.7..patch \
14 file://0002-fix-mm-vmscan-signatures-changed-in-linux-6.7.0-rc1.patch \
15 file://0001-wrapper-fdtable-adjust-fd-lookup-to-v6.7.patch \
Andrew Geissler615f2f12022-07-15 14:00:58 -050016 "
Patrick Williams03907ee2022-05-01 06:28:52 -050017
Andrew Geissler9aee5002022-03-30 16:27:02 +000018# Use :append here so that the patch is applied also when using devupstream
19SRC_URI:append = " file://0001-src-Kbuild-change-missing-CONFIG_TRACEPOINTS-to-warn.patch"
20
Andrew Geissler5082cc72023-09-11 08:41:39 -040021SRC_URI[sha256sum] = "13abfb1ac870711f0d0adfa88e53b17deb2e3052173715a260a6ef14aa45b0a7"
Andrew Geissler9aee5002022-03-30 16:27:02 +000022
23export INSTALL_MOD_DIR="kernel/lttng-modules"
24
25EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
26
27MODULES_MODULE_SYMVERS_LOCATION = "src"
28
29do_install:append() {
30 # Delete empty directories to avoid QA failures if no modules were built
31 if [ -d ${D}/${nonarch_base_libdir} ]; then
32 find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
33 fi
34}
35
36python do_package:prepend() {
37 if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
38 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
39}
40
41BBCLASSEXTEND = "devupstream:target"
Andrew Geissler028142b2023-05-05 11:29:21 -050042SRC_URI:class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.13;protocol=https"
Andrew Geissler9aee5002022-03-30 16:27:02 +000043SRCREV:class-devupstream = "7584cfc04914cb0842a986e9808686858b9c8630"
44SRCREV_FORMAT ?= "lttng_git"