Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | # |
| 2 | # Copyright (C) 2014 - 2017 Wind River Systems, Inc. |
| 3 | # |
| 4 | SUMMARY = "Base policy for CFEngine" |
| 5 | |
| 6 | DESCRIPTION = "CFEngine is an IT infrastructure automation framework \ |
| 7 | that helps engineers, system administrators and other stakeholders \ |
| 8 | in an IT system to manage and understand IT infrastructure throughout \ |
| 9 | its lifecycle. CFEngine takes systems from Build to Deploy, Manage and Audit. \ |
| 10 | \ |
| 11 | This package is intended to provide a stable base policy for \ |
| 12 | installations and upgrades, and is used by CFEngine 3.6 and newer. \ |
| 13 | \ |
| 14 | The contents of this packge are intended to live in `/var/cfengine/masterfiles` \ |
| 15 | or wherever `$(sys.masterdir)` points. \ |
| 16 | " |
| 17 | |
| 18 | HOMEPAGE = "http://cfengine.com" |
| 19 | |
| 20 | LICENSE = "MIT" |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 21 | LIC_FILES_CHKSUM = "file://LICENSE;md5=bb843e794feb6890f7697637b461c36e" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 22 | |
| 23 | SRC_URI = "https://cfengine-package-repos.s3.amazonaws.com/tarballs/${BP}.tar.gz \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 24 | " |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 25 | #SRC_URI[md5sum] = "5df2f85c75efc351ffadebcc11046a98" |
| 26 | SRC_URI[sha256sum] = "013ebe68599915cedb4bf753b471713d91901a991623358b9a967d9a779bcc16" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 27 | |
| 28 | inherit autotools |
| 29 | |
| 30 | export EXPLICIT_VERSION="${PV}" |
| 31 | |
| 32 | EXTRA_OECONF = "--prefix=${datadir}/cfengine" |
| 33 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 34 | do_install:append() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 35 | rm -rf ${D}${datadir}/cfengine/modules/packages/zypper ${D}${datadir}/cfengine/modules/packages/yum |
| 36 | } |
| 37 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 38 | FILES:${PN} = "${datadir}/cfengine" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 39 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 40 | RDEPENDS:${PN} += "python3-core" |