Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | DESCRIPTION = "libblockdev is a C library supporting GObject introspection for manipulation of \ |
| 2 | block devices. It has a plugin-based architecture where each technology (like \ |
| 3 | LVM, Btrfs, MD RAID, Swap,...) is implemented in a separate plugin, possibly \ |
| 4 | with multiple implementations (e.g. using LVM CLI or the new LVM DBus API)." |
| 5 | HOMEPAGE = "http://rhinstaller.github.io/libblockdev/" |
| 6 | LICENSE = "LGPL-2.0-or-later" |
| 7 | SECTION = "devel/lib" |
| 8 | |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c" |
| 10 | |
| 11 | inherit autotools gobject-introspection pkgconfig lib_package |
| 12 | |
| 13 | DEPENDS = "autoconf-archive-native glib-2.0 kmod udev libnvme" |
| 14 | |
| 15 | SRC_URI = "git://github.com/storaged-project/libblockdev;branch=master;protocol=https \ |
| 16 | file://0001-fix-pythondir-for-multilib-when-cross-compiling.patch \ |
| 17 | " |
| 18 | SRCREV = "ec0120de06f28ecfc10953b712f7f42735787bcf" |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | FILES:${PN} += "${libdir}/python3.*/site-packages" |
| 22 | |
| 23 | PACKAGECONFIG ??= "python3 lvm lvm-dbus dm parted fs escrow btrfs crypto mdraid mpath nvdimm tools" |
| 24 | PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3" |
| 25 | PACKAGECONFIG[lvm] = "--with-lvm, --without-lvm, multipath-tools, lvm2" |
| 26 | PACKAGECONFIG[lvm-dbus] = "--with-lvm_dbus, --without-lvm_dbus, multipath-tools, lvm2" |
| 27 | PACKAGECONFIG[dm] = "--with-dm, --without-dm, multipath-tools, lvm2" |
| 28 | PACKAGECONFIG[parted] = "--with-part, --without-part, parted" |
| 29 | PACKAGECONFIG[fs] = "--with-fs, --without-fs, util-linux" |
| 30 | PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native" |
| 31 | PACKAGECONFIG[nvdimm] = "--with-nvdimm, --without-nvdimm, ndctl util-linux" |
| 32 | PACKAGECONFIG[escrow] = "--with-escrow, --without-escrow, nss volume-key" |
| 33 | PACKAGECONFIG[btrfs] = "--with-btrfs,--without-btrfs,libbytesize btrfs-tools" |
| 34 | PACKAGECONFIG[crypto] = "--with-crypto,--without-crypto,cryptsetup nss volume-key" |
| 35 | PACKAGECONFIG[mdraid] = "--with-mdraid,--without-mdraid,libbytesize" |
| 36 | PACKAGECONFIG[mpath] = "--with-mpath,--without-mpath, multipath-tools, lvm2" |
| 37 | PACKAGECONFIG[tools] = "--with-tools,--without-tools,libbytesize libdevmapper" |
| 38 | |
| 39 | export GIR_EXTRA_LIBS_PATH="${B}/src/utils/.libs" |