Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "JSON-GLib implements a full JSON parser using GLib and GObject" |
| 2 | DESCRIPTION = "Use JSON-GLib it is possible to parse and generate valid JSON\ |
| 3 | data structures, using a DOM-like API. JSON-GLib also offers GObject \ |
| 4 | integration, providing the ability to serialize and deserialize GObject \ |
| 5 | instances to and from JSON data types." |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 6 | HOMEPAGE = "https://wiki.gnome.org/Projects/JsonGlib" |
| 7 | BUGTRACKER = "https://gitlab.gnome.org/GNOME/json-glib/issues" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 8 | |
| 9 | LICENSE = "LGPLv2.1" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34" |
| 11 | |
| 12 | DEPENDS = "glib-2.0" |
| 13 | |
| 14 | GNOMEBASEBUILDCLASS = "meson" |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame^] | 15 | inherit gnomebase lib_package gobject-introspection gi-docgen gettext ptest-gnome manpages upstream-version-is-even |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 16 | GIR_MESON_ENABLE_FLAG = 'enabled' |
| 17 | GIR_MESON_DISABLE_FLAG = 'disabled' |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame^] | 18 | GIDOCGEN_MESON_ENABLE_FLAG = 'enabled' |
| 19 | GIDOCGEN_MESON_DISABLE_FLAG = 'disabled' |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 20 | |
Andrew Geissler | 9b4d8b0 | 2021-02-19 12:26:16 -0600 | [diff] [blame] | 21 | SRC_URI += " file://run-ptest" |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame^] | 22 | SRC_URI[archive.sha256sum] = "b1f6a7930808f77a827f3b397a04bb89d4c0c0b2550885d4a5e4c411dfa13f5f" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 23 | |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 24 | PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 25 | PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxslt-native xmlto-native" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 26 | PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 27 | |
| 28 | BBCLASSEXTEND = "native nativesdk" |
| 29 | |
| 30 | # Currently it's not possible to disable gettext in Meson, so we need to force |
| 31 | # this back on. |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 32 | USE_NLS:class-native = "yes" |