Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Audio format Conversion library" |
| 2 | DESCRIPTION = "Library for reading and writing files containing sampled \ |
| 3 | sound (such as MS Windows WAV and the Apple/SGI AIFF format) through \ |
| 4 | one standard library interface." |
| 5 | HOMEPAGE = "https://libsndfile.github.io/libsndfile/" |
| 6 | AUTHOR = "Erik de Castro Lopo" |
| 7 | DEPENDS = "flac libogg libvorbis" |
| 8 | SECTION = "libs/multimedia" |
| 9 | LICENSE = "LGPL-2.1-only" |
| 10 | |
| 11 | SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/libsndfile-${PV}.tar.xz \ |
| 12 | file://noopus.patch \ |
| 13 | " |
| 14 | GITHUB_BASE_URI = "https://github.com/libsndfile/libsndfile/releases/" |
| 15 | |
| 16 | SRC_URI[sha256sum] = "0e30e7072f83dc84863e2e55f299175c7e04a5902ae79cfb99d4249ee8f6d60a" |
| 17 | |
| 18 | LIC_FILES_CHKSUM = "file://COPYING;md5=e77fe93202736b47c07035910f47974a" |
| 19 | |
| 20 | CVE_PRODUCT = "libsndfile" |
| 21 | |
| 22 | S = "${WORKDIR}/libsndfile-${PV}" |
| 23 | |
| 24 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'alsa', d)}" |
| 25 | PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib" |
| 26 | PACKAGECONFIG[regtest] = "--enable-sqlite,--disable-sqlite,sqlite3" |
| 27 | |
| 28 | inherit autotools lib_package pkgconfig multilib_header github-releases |
| 29 | |
| 30 | do_install:append() { |
| 31 | oe_multilib_header sndfile.h |
| 32 | } |