Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Tools for monitoring & limiting user disk usage per filesystem" |
| 2 | SECTION = "base" |
| 3 | HOMEPAGE = "http://sourceforge.net/projects/linuxquota/" |
| 4 | BUGTRACKER = "http://sourceforge.net/tracker/?group_id=18136&atid=118136" |
| 5 | LICENSE = "BSD & GPLv2+ & LGPLv2.1+" |
| 6 | LIC_FILES_CHKSUM = "file://quota.c;beginline=1;endline=33;md5=331c7d77744bfe0ad24027f0651028ec \ |
| 7 | file://rquota_server.c;beginline=1;endline=20;md5=fe7e0d7e11c6f820f8fa62a5af71230f \ |
| 8 | file://svc_socket.c;beginline=1;endline=17;md5=24d5a8792da45910786eeac750be8ceb" |
| 9 | |
| 10 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/linuxquota/quota-tools/${PV}/quota-${PV}.tar.gz \ |
| 11 | file://fcntl.patch \ |
| 12 | file://remove_non_posix_types.patch \ |
| 13 | " |
| 14 | SRC_URI_append_libc-musl = " file://replace_getrpcbynumber_r.patch" |
| 15 | |
| 16 | SRC_URI[md5sum] = "f46f3b0b5141f032f25684005dac49d3" |
| 17 | SRC_URI[sha256sum] = "735be1887e7f51f54165e778ae43fc859c04e44d88834ecb2f470e91d4ef8edf" |
| 18 | |
| 19 | CVE_PRODUCT = "linux_diskquota" |
| 20 | |
| 21 | UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/linuxquota/files/quota-tools/" |
| 22 | UPSTREAM_CHECK_REGEX = "/quota-tools/(?P<pver>(\d+[\.\-_]*)+)/" |
| 23 | |
| 24 | DEPENDS = "gettext-native e2fsprogs libnl dbus" |
| 25 | |
| 26 | inherit autotools-brokensep gettext pkgconfig |
| 27 | |
| 28 | CFLAGS += "${@bb.utils.contains('PACKAGECONFIG', 'rpc', '-I${STAGING_INCDIR}/tirpc', '', d)}" |
| 29 | LDFLAGS += "${@bb.utils.contains('PACKAGECONFIG', 'rpc', '-ltirpc', '', d)}" |
| 30 | ASNEEDED = "" |
| 31 | |
| 32 | PACKAGECONFIG ??= "tcp-wrappers rpc bsd" |
| 33 | PACKAGECONFIG_libc-musl = "tcp-wrappers rpc" |
| 34 | |
| 35 | PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers" |
| 36 | PACKAGECONFIG[rpc] = "--enable-rpc,--disable-rpc,libtirpc" |
| 37 | PACKAGECONFIG[bsd] = "--enable-bsd_behaviour=yes,--enable-bsd_behaviour=no," |
| 38 | PACKAGECONFIG[ldapmail] = "--enable-ldapmail,--disable-ldapmail,openldap" |