blob: 1fd36a266fdebeb042efb8f462205cc20994fdff [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "A suite of security-related network utilities based on \
2the SSH protocol including the ssh client and sshd server"
3DESCRIPTION = "Secure rlogin/rsh/rcp/telnet replacement (OpenSSH) \
4Ssh (Secure Shell) is a program for logging into a remote machine \
5and for executing commands on a remote machine."
6HOMEPAGE = "http://www.openssh.com/"
7SECTION = "console/network"
8LICENSE = "BSD-2-Clause & BSD-3-Clause & ISC & MIT"
9LIC_FILES_CHKSUM = "file://LICENCE;md5=072979064e691d342002f43cd89c0394"
10
11DEPENDS = "zlib openssl virtual/crypt"
12DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
13
14SRC_URI = "http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-${PV}.tar.gz \
15 file://sshd_config \
16 file://ssh_config \
17 file://init \
18 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \
19 file://sshd.service \
20 file://sshd.socket \
21 file://sshd@.service \
22 file://sshdgenkeys.service \
23 file://volatiles.99_sshd \
24 file://run-ptest \
25 file://fix-potential-signed-overflow-in-pointer-arithmatic.patch \
26 file://sshd_check_keys \
27 file://add-test-support-for-busybox.patch \
28 file://0001-regress-banner.sh-log-input-and-output-files-on-erro.patch \
29 file://0001-systemd-Add-optional-support-for-systemd-sd_notify.patch \
30 "
Patrick Williams73bd93f2024-02-20 08:07:48 -060031SRC_URI[sha256sum] = "910211c07255a8c5ad654391b40ee59800710dd8119dd5362de09385aa7a777c"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060032
33CVE_STATUS[CVE-2007-2768] = "not-applicable-config: This CVE is specific to OpenSSH with the pam opie which we don't build/use here."
34
35# This CVE is specific to OpenSSH server, as used in Fedora and Red Hat Enterprise Linux 7
36# and when running in a Kerberos environment. As such it is not relevant to OpenEmbedded
37CVE_STATUS[CVE-2014-9278] = "not-applicable-platform: This CVE is specific to OpenSSH server, as used in Fedora and \
38Red Hat Enterprise Linux 7 and when running in a Kerberos environment"
39
40CVE_STATUS[CVE-2008-3844] = "not-applicable-platform: Only applies to some distributed RHEL binaries."
41
42PAM_SRC_URI = "file://sshd"
43
44inherit manpages useradd update-rc.d update-alternatives systemd
45
46USERADD_PACKAGES = "${PN}-sshd"
47USERADD_PARAM:${PN}-sshd = "--system --no-create-home --home-dir /var/run/sshd --shell /bin/false --user-group sshd"
48INITSCRIPT_PACKAGES = "${PN}-sshd"
49INITSCRIPT_NAME:${PN}-sshd = "sshd"
50INITSCRIPT_PARAMS:${PN}-sshd = "defaults 9"
51
52SYSTEMD_PACKAGES = "${PN}-sshd"
Patrick Williams705982a2024-01-12 09:51:57 -060053SYSTEMD_SERVICE:${PN}-sshd = "${@bb.utils.contains('PACKAGECONFIG','systemd-sshd-socket-mode','sshd.socket', '', d)} ${@bb.utils.contains('PACKAGECONFIG','systemd-sshd-service-mode','sshd.service', '', d)}"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060054
55inherit autotools-brokensep ptest pkgconfig
56DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
57
Patrick Williams705982a2024-01-12 09:51:57 -060058# systemd-sshd-socket-mode means installing sshd.socket
59# and systemd-sshd-service-mode corresponding to sshd.service
60PACKAGECONFIG ??= "systemd-sshd-socket-mode"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060061PACKAGECONFIG[kerberos] = "--with-kerberos5,--without-kerberos5,krb5"
62PACKAGECONFIG[ldns] = "--with-ldns,--without-ldns,ldns"
63PACKAGECONFIG[libedit] = "--with-libedit,--without-libedit,libedit"
64PACKAGECONFIG[manpages] = "--with-mantype=man,--with-mantype=cat"
Patrick Williams705982a2024-01-12 09:51:57 -060065PACKAGECONFIG[systemd-sshd-socket-mode] = ""
66PACKAGECONFIG[systemd-sshd-service-mode] = ""
Patrick Williamsac13d5f2023-11-24 18:59:46 -060067
68EXTRA_AUTORECONF += "--exclude=aclocal"
69
70# login path is hardcoded in sshd
71EXTRA_OECONF = "'LOGIN_PROGRAM=${base_bindir}/login' \
72 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '--with-pam', '--without-pam', d)} \
73 --without-zlib-version-check \
74 --with-privsep-path=${localstatedir}/run/sshd \
75 --sysconfdir=${sysconfdir}/ssh \
76 --with-xauth=${bindir}/xauth \
77 --disable-strip \
78 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--with-systemd', '--without-systemd', d)} \
79 "
80
81# musl doesn't implement wtmp/utmp and logwtmp
82EXTRA_OECONF:append:libc-musl = " --disable-wtmp --disable-lastlog"
83
Patrick Williams73bd93f2024-02-20 08:07:48 -060084# Work around ICE on mips/mips64 starting in 9.6p1
85EXTRA_OECONF:append:mips = " --without-hardening"
86EXTRA_OECONF:append:mips64 = " --without-hardening"
87
Patrick Williamsac13d5f2023-11-24 18:59:46 -060088# Since we do not depend on libbsd, we do not want configure to use it
89# just because it finds libutil.h. But, specifying --disable-libutil
90# causes compile errors, so...
91CACHED_CONFIGUREVARS += "ac_cv_header_bsd_libutil_h=no ac_cv_header_libutil_h=no"
92
93# passwd path is hardcoded in sshd
94CACHED_CONFIGUREVARS += "ac_cv_path_PATH_PASSWD_PROG=${bindir}/passwd"
95
96# We don't want to depend on libblockfile
97CACHED_CONFIGUREVARS += "ac_cv_header_maillock_h=no"
98
99do_configure:prepend () {
100 export LD="${CC}"
101 install -m 0644 ${WORKDIR}/sshd_config ${B}/
102 install -m 0644 ${WORKDIR}/ssh_config ${B}/
103}
104
105do_compile_ptest() {
106 oe_runmake regress-binaries regress-unit-binaries
107}
108
109do_install:append () {
110 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}" ]; then
111 install -D -m 0644 ${WORKDIR}/sshd ${D}${sysconfdir}/pam.d/sshd
112 sed -i -e 's:#UsePAM no:UsePAM yes:' ${D}${sysconfdir}/ssh/sshd_config
113 fi
114
115 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" ]; then
116 sed -i -e 's:#X11Forwarding no:X11Forwarding yes:' ${D}${sysconfdir}/ssh/sshd_config
117 fi
118
119 install -d ${D}${sysconfdir}/init.d
120 install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/sshd
121 rm -f ${D}${bindir}/slogin ${D}${datadir}/Ssh.bin
122 rmdir ${D}${localstatedir}/run/sshd ${D}${localstatedir}/run ${D}${localstatedir}
123 install -d ${D}/${sysconfdir}/default/volatiles
124 install -m 644 ${WORKDIR}/volatiles.99_sshd ${D}/${sysconfdir}/default/volatiles/99_sshd
125 install -m 0755 ${S}/contrib/ssh-copy-id ${D}${bindir}
126
127 # Create config files for read-only rootfs
128 install -d ${D}${sysconfdir}/ssh
129 install -m 644 ${D}${sysconfdir}/ssh/sshd_config ${D}${sysconfdir}/ssh/sshd_config_readonly
130 sed -i '/HostKey/d' ${D}${sysconfdir}/ssh/sshd_config_readonly
131 echo "HostKey /var/run/ssh/ssh_host_rsa_key" >> ${D}${sysconfdir}/ssh/sshd_config_readonly
132 echo "HostKey /var/run/ssh/ssh_host_ecdsa_key" >> ${D}${sysconfdir}/ssh/sshd_config_readonly
133 echo "HostKey /var/run/ssh/ssh_host_ed25519_key" >> ${D}${sysconfdir}/ssh/sshd_config_readonly
134
135 install -d ${D}${systemd_system_unitdir}
Patrick Williams705982a2024-01-12 09:51:57 -0600136 if ${@bb.utils.contains('PACKAGECONFIG','systemd-sshd-socket-mode','true','false',d)}; then
137 install -c -m 0644 ${WORKDIR}/sshd.socket ${D}${systemd_system_unitdir}
138 install -c -m 0644 ${WORKDIR}/sshd@.service ${D}${systemd_system_unitdir}
139 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
140 -e 's,@SBINDIR@,${sbindir},g' \
141 -e 's,@BINDIR@,${bindir},g' \
142 -e 's,@LIBEXECDIR@,${libexecdir}/${BPN},g' \
143 ${D}${systemd_system_unitdir}/sshd.socket
144 fi
145 if ${@bb.utils.contains('PACKAGECONFIG','systemd-sshd-service-mode','true','false',d)}; then
146 install -c -m 0644 ${WORKDIR}/sshd.service ${D}${systemd_system_unitdir}
147 fi
Patrick Williamsac13d5f2023-11-24 18:59:46 -0600148 install -c -m 0644 ${WORKDIR}/sshdgenkeys.service ${D}${systemd_system_unitdir}
149 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
150 -e 's,@SBINDIR@,${sbindir},g' \
151 -e 's,@BINDIR@,${bindir},g' \
152 -e 's,@LIBEXECDIR@,${libexecdir}/${BPN},g' \
Patrick Williams705982a2024-01-12 09:51:57 -0600153 ${D}${systemd_system_unitdir}/*.service
Patrick Williamsac13d5f2023-11-24 18:59:46 -0600154
155 sed -i -e 's,@LIBEXECDIR@,${libexecdir}/${BPN},g' \
156 ${D}${sysconfdir}/init.d/sshd
157
158 install -D -m 0755 ${WORKDIR}/sshd_check_keys ${D}${libexecdir}/${BPN}/sshd_check_keys
159}
160
161do_install_ptest () {
162 sed -i -e "s|^SFTPSERVER=.*|SFTPSERVER=${libexecdir}/sftp-server|" regress/test-exec.sh
163 cp -r regress ${D}${PTEST_PATH}
164 cp config.h ${D}${PTEST_PATH}
165}
166
167ALLOW_EMPTY:${PN} = "1"
168
169PACKAGES =+ "${PN}-keygen ${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-sftp ${PN}-misc ${PN}-sftp-server"
170FILES:${PN}-scp = "${bindir}/scp.${BPN}"
171FILES:${PN}-ssh = "${bindir}/ssh.${BPN} ${sysconfdir}/ssh/ssh_config"
172FILES:${PN}-sshd = "${sbindir}/sshd ${sysconfdir}/init.d/sshd ${systemd_system_unitdir}"
173FILES:${PN}-sshd += "${sysconfdir}/ssh/moduli ${sysconfdir}/ssh/sshd_config ${sysconfdir}/ssh/sshd_config_readonly ${sysconfdir}/default/volatiles/99_sshd ${sysconfdir}/pam.d/sshd"
174FILES:${PN}-sshd += "${libexecdir}/${BPN}/sshd_check_keys"
175FILES:${PN}-sftp = "${bindir}/sftp"
176FILES:${PN}-sftp-server = "${libexecdir}/sftp-server"
177FILES:${PN}-misc = "${bindir}/ssh* ${libexecdir}/ssh*"
178FILES:${PN}-keygen = "${bindir}/ssh-keygen"
179
180RDEPENDS:${PN} += "${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-keygen ${PN}-sftp-server"
181RDEPENDS:${PN}-sshd += "${PN}-keygen ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam-plugin-keyinit pam-plugin-loginuid', '', d)}"
182# gdb would make attach-ptrace test pass rather than skip but not worth the build dependencies
183RDEPENDS:${PN}-ptest += "${PN}-sftp ${PN}-misc ${PN}-sftp-server make sed coreutils openssl-bin"
184
185RPROVIDES:${PN}-ssh = "ssh"
186RPROVIDES:${PN}-sshd = "sshd"
187
188RCONFLICTS:${PN} = "dropbear"
189RCONFLICTS:${PN}-sshd = "dropbear"
190
191CONFFILES:${PN}-sshd = "${sysconfdir}/ssh/sshd_config"
192CONFFILES:${PN}-ssh = "${sysconfdir}/ssh/ssh_config"
193
194ALTERNATIVE_PRIORITY = "90"
195ALTERNATIVE:${PN}-scp = "scp"
196ALTERNATIVE:${PN}-ssh = "ssh"
197
198BBCLASSEXTEND += "nativesdk"