Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 1 | SUMMARY = "Compressor/archiver for creating and modifying .zip files" |
| 2 | HOMEPAGE = "http://www.info-zip.org" |
| 3 | SECTION = "console/utils" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 4 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 5 | LICENSE = "BSD-3-Clause" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=04d43c5d70b496c032308106e26ae17d" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 7 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 8 | PR = "r2" |
| 9 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 10 | S = "${WORKDIR}/zip30" |
| 11 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 12 | SRC_URI = "${SOURCEFORGE_MIRROR}/infozip/Zip%203.x%20%28latest%29/3.0/zip30.tar.gz \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 13 | file://fix-security-format.patch \ |
| 14 | file://10-remove-build-date.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | file://zipnote-crashes-with-segfault.patch \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 16 | " |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 17 | UPSTREAM_VERSION_UNKNOWN = "1" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 18 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 19 | SRC_URI[md5sum] = "7b74551e63f8ee6aab6fbc86676c0d37" |
| 20 | SRC_URI[sha256sum] = "f0e8bb1f9b7eb0b01285495a2699df3a4b766784c1765a8f1aeedf63c0806369" |
| 21 | |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame^] | 22 | # Disputed and also Debian doesn't consider a vulnerability |
| 23 | CVE_CHECK_WHITELIST += "CVE-2018-13410" |
| 24 | |
| 25 | # Not for zip but for smart contract implementation for it |
| 26 | CVE_CHECK_WHITELIST += "CVE-2018-13684" |
| 27 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 28 | # zip.inc sets CFLAGS, but what Makefile actually uses is |
| 29 | # CFLAGS_NOOPT. It will also force -O3 optimization, overriding |
| 30 | # whatever we set. |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 31 | EXTRA_OEMAKE = "'CC=${CC}' 'BIND=${CC}' 'AS=${CC} -c' 'CPP=${CPP}' \ |
| 32 | 'CFLAGS=-I. -DUNIX ${CFLAGS}' \ |
| 33 | 'CFLAGS_NOOPT=-I. -DUNIX ${CFLAGS}' \ |
| 34 | 'INSTALL=install' 'INSTALL_D=install -d' \ |
| 35 | 'BINFLAGS=0755'" |
| 36 | |
| 37 | do_compile() { |
| 38 | oe_runmake -f unix/Makefile flags IZ_BZIP2=no_such_directory |
| 39 | sed -i 's#LFLAGS1=""#LFLAGS1="${LDFLAGS}"#' flags |
| 40 | oe_runmake -f unix/Makefile generic IZ_BZIP2=no_such_directory |
| 41 | } |
| 42 | |
| 43 | do_install() { |
| 44 | oe_runmake -f unix/Makefile prefix=${D}${prefix} \ |
| 45 | BINDIR=${D}${bindir} MANDIR=${D}${mandir}/man1 \ |
| 46 | install |
| 47 | } |
| 48 | |
| 49 | BBCLASSEXTEND = "native" |
| 50 | |
| 51 | # exclude version 2.3.2 which triggers a false positive |
| 52 | UPSTREAM_CHECK_REGEX = "^zip(?P<pver>(?!232).+)\.tgz" |