blob: dc30926c59b23c453bdea47cb1da60cad28d927d [file] [log] [blame]
Andrew Geissler4ed12e12020-06-05 18:00:41 -05001SUMMARY = "Library for reading extended image information (EXIF) from JPEG files"
2HOMEPAGE = "https://libexif.github.io/"
3SECTION = "libs"
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://COPYING;md5=243b725d71bb5df4a1e5920b344b86ad"
6
7def version_underscore(v):
8 return "_".join(v.split("."))
9
10SRC_URI = "https://github.com/libexif/libexif/releases/download/libexif-${@version_underscore("${PV}")}-release/libexif-${PV}.tar.xz \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060011 file://CVE-2020-0198.patch \
12 file://CVE-2020-0452.patch \
Andrew Geissler4ed12e12020-06-05 18:00:41 -050013 "
14
15SRC_URI[sha256sum] = "5048f1c8fc509cc636c2f97f4b40c293338b6041a5652082d5ee2cf54b530c56"
16
17UPSTREAM_CHECK_URI = "https://github.com/libexif/libexif/releases/"
18
19inherit autotools gettext
20
21EXTRA_OECONF += "--disable-docs"
Andrew Geissler635e0e42020-08-21 15:58:33 -050022
23BBCLASSEXTEND = "native nativesdk"