Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 1 | PR = "r1" |
| 2 | PV = "0.1+git${SRCPV}" |
| 3 | LICENSE = "GPL-2.0-or-later" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4325afd396febcb659c36b49533135d4" |
| 5 | |
| 6 | SRC_URI = "git://github.com/mstpd/mstpd;branch=master;protocol=https" |
| 7 | SRCREV = "181c453fc1a00573e19f14960dcc54ad84beea7c" |
| 8 | S = "${WORKDIR}/git" |
| 9 | |
| 10 | SRC_URI:append = " \ |
| 11 | file://bridge-stp \ |
| 12 | file://mstpd.service \ |
| 13 | " |
| 14 | |
| 15 | inherit autotools pkgconfig systemd |
| 16 | |
| 17 | PACKAGES =+ "${PN}-mstpd" |
| 18 | FILES:${PN}-mstpd = "${sbindir}/mstpd ${sbindir}/mstpctl ${sbindir}/bridge-stp" |
| 19 | |
| 20 | SYSTEMD_PACKAGES = "${PN}-mstpd" |
| 21 | SYSTEMD_SERVICE:${PN}-mstpd = "mstpd.service" |
| 22 | |
| 23 | do_install:append() { |
| 24 | rm -rf ${D}${libexecdir} ${D}${libdir}/NetworkManager |
| 25 | rmdir ${D}${libdir} || true |
| 26 | |
| 27 | install -d -m 0755 ${D}/${sbindir} |
| 28 | install -m 0755 ${WORKDIR}/bridge-stp ${D}/${sbindir} |
| 29 | |
| 30 | install -d -m 0755 ${D}${systemd_system_unitdir} |
| 31 | install -m 0644 ${WORKDIR}/mstpd.service ${D}${systemd_system_unitdir}/ |
| 32 | } |