Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Protocol Buffers" |
| 2 | HOMEPAGE = "https://developers.google.com/protocol-buffers/" |
| 3 | SECTION = "devel/python" |
| 4 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 5 | LICENSE = "BSD-3-Clause" |
Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=19e8f490f9526b1de84f8d949cfcfd4e" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 7 | |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 8 | inherit pypi setuptools3 |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 9 | |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 10 | SRC_URI[md5sum] = "b4336acee38ebe915b6e72fe8c5bce7b" |
| 11 | SRC_URI[sha256sum] = "49ef8ab4c27812a89a76fa894fe7a08f42f2147078392c0dee51d4a444ef6df5" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 12 | |
| 13 | # http://errors.yoctoproject.org/Errors/Details/184715/ |
| 14 | # Can't find required file: ../src/google/protobuf/descriptor.proto |
| 15 | CLEANBROKEN = "1" |
| 16 | |
| 17 | UPSTREAM_CHECK_REGEX = "protobuf/(?P<pver>\d+(\.\d+)+)/" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 18 | |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 19 | DEPENDS += "protobuf" |
| 20 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 21 | RDEPENDS_${PN} += " \ |
| 22 | ${PYTHON_PN}-datetime \ |
| 23 | ${PYTHON_PN}-json \ |
| 24 | ${PYTHON_PN}-logging \ |
| 25 | ${PYTHON_PN}-netclient \ |
| 26 | ${PYTHON_PN}-numbers \ |
| 27 | ${PYTHON_PN}-pkgutil \ |
| 28 | ${PYTHON_PN}-six \ |
| 29 | ${PYTHON_PN}-unittest \ |
| 30 | " |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 31 | |
| 32 | # For usage in other recipies when compiling protobuf files (e.g. by grpcio-tools) |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 33 | BBCLASSEXTEND = "native nativesdk" |
| 34 | |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 35 | DISTUTILS_BUILD_ARGS += "--cpp_implementation" |
| 36 | DISTUTILS_INSTALL_ARGS += "--cpp_implementation" |
| 37 | |
| 38 | do_compile_prepend_class-native () { |
| 39 | export KOKORO_BUILD_NUMBER="1" |
| 40 | } |