blob: ef6375546e9e6a0e87e2648e81cd1908fefcab36 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Twisted Web Sockets"
2HOMEPAGE = "https://github.com/MostAwesomeDude/txWS"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=76699830db7fa9e897f6a1ad05f98ec8"
6
7DEPENDS = "python3-twisted python3-six python3-vcversioner python3-six-native python3-vcversioner-native"
8
Patrick Williamsb542dec2023-06-09 01:26:37 -05009RDEPENDS:${PN} += " \
10 python3-six \
11 python3-twisted \
12"
13
Andrew Geissler595f6302022-01-24 19:11:47 +000014SRC_URI = "git://github.com/MostAwesomeDude/txWS.git;branch=master;protocol=https"
Andrew Geissler82c905d2020-04-13 13:39:40 -050015SRCREV= "88cf6d9b9b685ffa1720644bd53c742afb10a414"
16
17S = "${WORKDIR}/git"
18
19inherit setuptools3
20
Andrew Geissler9aee5002022-03-30 16:27:02 +000021PIP_INSTALL_PACKAGE = "txWS"