blob: 52b3aa7dc77d34bedbbabcbdc5725f8c38472e81 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001DESCRIPTION = "A python module for system storage configuration"
2HOMEPAGE = "http://fedoraproject.org/wiki/blivet"
3LICENSE = "LGPL-2.0-or-later"
4SECTION = "devel/python"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8SRC_URI += "\
9 file://0002-run_program-support-timeout.patch \
10 file://0003-support-infinit-timeout.patch \
11 file://0005-fix-incorrect-timeout-while-system-time-changed.patch \
12 file://0006-tweak-btrfs-packages.patch \
13 file://0007-invoking-mount-with-infinite-timeout.patch \
14 file://0008-use-oe-variable-to-replace-hardcoded-dir.patch \
15 file://0009-invoking-fsck-with-infinite-timeout.patch \
16 file://0010-invoking-mkfs-with-infinite-timeout.patch \
17 file://0011-invoking-dd-with-infinite-timeout.patch \
18"
19SRC_URI[sha256sum] = "88d1500c76c4660aec7da9e9aa54f7f574546571b52c07a67e1417883c2cb25b"
20
21inherit pypi features_check systemd setuptools3_legacy
22
23REQUIRED_DISTRO_FEATURES = "systemd"
24
25RDEPENDS:${PN} += "python3-pykickstart python3-pyudev \
26 parted python3-pyparted multipath-tools \
27 lsof cryptsetup libblockdev \
28 libbytesize \
29"
30
31FILES:${PN} += " \
32 ${datadir}/dbus-1/system-services \
33"
34
35SYSTEMD_AUTO_ENABLE = "disable"
36SYSTEMD_SERVICE:${PN} = "blivet.service"