Brad Bishop | 0a92126 | 2019-09-24 07:40:45 -0400 | [diff] [blame] | 1 | SUMMARY = "Jpeg 2000 implementation" |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 2 | HOMEPAGE = "https://jasper-software.github.io/jasper/" |
Brad Bishop | 0a92126 | 2019-09-24 07:40:45 -0400 | [diff] [blame] | 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a80440d1d8f17d041c71c7271d6e06eb" |
| 5 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 6 | SRC_URI = "git://github.com/jasper-software/jasper.git;protocol=https" |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 7 | SRCREV = "5083b949f0caa5bc6257cd81162a33c15bf8a1d1" |
Brad Bishop | 0a92126 | 2019-09-24 07:40:45 -0400 | [diff] [blame] | 8 | |
| 9 | S = "${WORKDIR}/git" |
| 10 | |
| 11 | inherit cmake |
| 12 | |
| 13 | PACKAGECONFIG ??= "" |
| 14 | PACKAGECONFIG[jpeg] = "-DJAS_ENABLE_LIBJPEG=true, -DJAS_ENABLE_LIBJPEG=false, jpeg" |
| 15 | PACKAGECONFIG[opengl] = "-DJAS_ENABLE_OPENGL=true, -DJAS_ENABLE_OPENGL=false, freeglut" |
| 16 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 17 | EXTRA_OECMAKE:append = " -DJAS_ENABLE_SHARED=true" |
Brad Bishop | 0a92126 | 2019-09-24 07:40:45 -0400 | [diff] [blame] | 18 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 19 | do_install:append() { |
Brad Bishop | 0a92126 | 2019-09-24 07:40:45 -0400 | [diff] [blame] | 20 | chrpath -d ${D}${bindir}/jasper |
| 21 | chrpath -d ${D}${bindir}/imginfo |
| 22 | chrpath -d ${D}${bindir}/imgcmp |
| 23 | chrpath -d ${D}${libdir}/libjasper.so.* |
| 24 | } |