Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | require ${BPN}.inc |
| 2 | |
| 3 | DEPENDS = "${BPN}-native alsa-lib ncurses glib-2.0" |
| 4 | |
| 5 | SRC_URI += " \ |
| 6 | file://0001-Do-not-build-gentables-helper-we-have-to-use-native-.patch \ |
| 7 | file://0002-fluid_synth_nwrite_float-Allow-zero-pointer-for-left.patch \ |
| 8 | file://0003-Use-ARM-NEON-accelaration-for-float-multithreaded-se.patch \ |
| 9 | " |
| 10 | |
| 11 | EXTRA_OECMAKE = "-Denable-floats=ON -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')}" |
| 12 | |
| 13 | do_configure_append() { |
| 14 | make_tables.exe ${B}/ |
| 15 | } |
| 16 | |
| 17 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio', d)}" |
| 18 | PACKAGECONFIG[sndfile] = "-Denable-libsndfile=ON,-Denable-libsndfile=OFF,libsndfile1" |
| 19 | PACKAGECONFIG[jack] = "-Denable-jack=ON,-Denable-jack=OFF,jack" |
| 20 | PACKAGECONFIG[pulseaudio] = "-Denable-pulseaudio=ON,-Denable-pulseaudio=OFF,pulseaudio" |
| 21 | PACKAGECONFIG[portaudio] = "-Denable-portaudio=ON,-Denable-portaudio=OFF,portaudio-v19" |
| 22 | PACKAGECONFIG[profiling] = "-Denable-profiling=ON,-Denable-profiling=OFF" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 23 | PACKAGECONFIG[readline] = "-Denable-readline=ON,-Denable-readline=OFF,readline" |