Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Hardware accelerated JPEG compression/decompression library" |
| 2 | DESCRIPTION = "libjpeg-turbo is a derivative of libjpeg that uses SIMD instructions (MMX, SSE2, NEON) to accelerate baseline JPEG compression and decompression" |
| 3 | HOMEPAGE = "http://libjpeg-turbo.org/" |
| 4 | |
| 5 | LICENSE = "BSD-3-Clause" |
| 6 | LIC_FILES_CHKSUM = "file://cdjpeg.h;endline=13;md5=8184bcc7c4ac7b9edc6a7bc00f231d0b \ |
| 7 | file://jpeglib.h;endline=16;md5=7ea97dc83b0f59052ee837e61ef0e08f \ |
| 8 | file://djpeg.c;endline=11;md5=c59e19811c006cb38f82d6477134d314 \ |
| 9 | " |
| 10 | DEPENDS_append_x86-64_class-target = " nasm-native" |
Andrew Geissler | 4ed12e1 | 2020-06-05 18:00:41 -0500 | [diff] [blame] | 11 | DEPENDS_append_x86_class-target = " nasm-native" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | |
| 13 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz \ |
| 14 | file://0001-libjpeg-turbo-fix-package_qa-error.patch \ |
| 15 | " |
| 16 | |
| 17 | SRC_URI[md5sum] = "d01d9e0c28c27bc0de9f4e2e8ff49855" |
| 18 | SRC_URI[sha256sum] = "33dd8547efd5543639e890efbf2ef52d5a21df81faf41bb940657af916a23406" |
| 19 | UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/libjpeg-turbo/files/" |
| 20 | UPSTREAM_CHECK_REGEX = "/libjpeg-turbo/files/(?P<pver>(\d+[\.\-_]*)+)/" |
| 21 | |
Andrew Geissler | 4ed12e1 | 2020-06-05 18:00:41 -0500 | [diff] [blame] | 22 | PE = "1" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 23 | |
| 24 | # Drop-in replacement for jpeg |
| 25 | PROVIDES = "jpeg" |
| 26 | RPROVIDES_${PN} += "jpeg" |
| 27 | RREPLACES_${PN} += "jpeg" |
| 28 | RCONFLICTS_${PN} += "jpeg" |
| 29 | |
| 30 | inherit cmake pkgconfig |
| 31 | |
| 32 | export NASMENV = "--debug-prefix-map=${WORKDIR}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}" |
| 33 | |
| 34 | # Add nasm-native dependency consistently for all build arches is hard |
| 35 | EXTRA_OECMAKE_append_class-native = " -DWITH_SIMD=False" |
| 36 | EXTRA_OECMAKE_append_class-nativesdk = " -DWITH_SIMD=False" |
| 37 | |
| 38 | # Work around missing x32 ABI support |
| 39 | EXTRA_OECMAKE_append_class-target = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", "-DWITH_SIMD=False", "", d)}" |
| 40 | |
| 41 | # Work around missing non-floating point ABI support in MIPS |
| 42 | EXTRA_OECMAKE_append_class-target = " ${@bb.utils.contains("MIPSPKGSFX_FPU", "-nf", "-DWITH_SIMD=False", "", d)}" |
| 43 | |
| 44 | # Provide a workaround if Altivec unit is not present in PPC |
| 45 | EXTRA_OECMAKE_append_class-target_powerpc = " ${@bb.utils.contains("TUNE_FEATURES", "altivec", "", "-DWITH_SIMD=False", d)}" |
| 46 | EXTRA_OECMAKE_append_class-target_powerpc64 = " ${@bb.utils.contains("TUNE_FEATURES", "altivec", "", "-DWITH_SIMD=False", d)}" |
| 47 | |
| 48 | DEBUG_OPTIMIZATION_append_armv4 = " ${@bb.utils.contains('TUNE_CCARGS', '-mthumb', '-fomit-frame-pointer', '', d)}" |
| 49 | DEBUG_OPTIMIZATION_append_armv5 = " ${@bb.utils.contains('TUNE_CCARGS', '-mthumb', '-fomit-frame-pointer', '', d)}" |
| 50 | |
| 51 | PACKAGES =+ "jpeg-tools libturbojpeg" |
| 52 | |
| 53 | DESCRIPTION_jpeg-tools = "The jpeg-tools package includes client programs to access libjpeg functionality. These tools allow for the compression, decompression, transformation and display of JPEG files and benchmarking of the libjpeg library." |
| 54 | FILES_jpeg-tools = "${bindir}/*" |
| 55 | |
| 56 | DESCRIPTION_libturbojpeg = "A SIMD-accelerated JPEG codec which provides only TurboJPEG APIs" |
| 57 | FILES_libturbojpeg = "${libdir}/libturbojpeg.so.*" |
| 58 | |
| 59 | BBCLASSEXTEND = "native nativesdk" |