blob: 5923544ecadb43aaa85303bdb192d9cdc762efad [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "GObject wrapper for libudev"
Brad Bishop64c979e2019-11-04 13:55:29 -05002DESCRIPTION = "This library makes it much simpler to use libudev from programs \
3already using GObject. It also makes it possible to easily use libudev from \
4other programming languages, such as Javascript, because of GObject \
5introspection support."
Brad Bishop316dfdd2018-06-25 12:45:53 -04006HOMEPAGE = "https://wiki.gnome.org/Projects/libgudev"
Brad Bishop64c979e2019-11-04 13:55:29 -05007BUGTRACKER = "https://gitlab.gnome.org/GNOME/libgudev/issues"
Andrew Geissler5082cc72023-09-11 08:41:39 -04008SRC_URI[archive.sha256sum] = "61266ab1afc9d73dbc60a8b2af73e99d2fdff47d99544d085760e4fa667b5dd1"
Brad Bishop316dfdd2018-06-25 12:45:53 -04009
Patrick Williams8e7b46e2023-05-01 14:19:06 -050010DEPENDS = "glib-2.0 glib-2.0-native udev"
Brad Bishop316dfdd2018-06-25 12:45:53 -040011
Patrick Williams213cb262021-08-07 19:21:33 -050012RCONFLICTS:${PN} = "systemd (<= 220)"
Brad Bishop316dfdd2018-06-25 12:45:53 -040013
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000014LICENSE = "LGPL-2.1-only"
Brad Bishop316dfdd2018-06-25 12:45:53 -040015LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
16
17inherit gnomebase gobject-introspection gtk-doc
18
William A. Kennington IIIac69b482021-06-02 12:28:27 -070019GIR_MESON_ENABLE_FLAG = 'enabled'
20GIR_MESON_DISABLE_FLAG = 'disabled'
21
22GTKDOC_MESON_OPTION = "gtk_doc"
23
Brad Bishop316dfdd2018-06-25 12:45:53 -040024UPSTREAM_CHECK_URI = "http://ftp.gnome.org/pub/GNOME/sources/libgudev/"
25UPSTREAM_CHECK_REGEX = "(?P<pver>(\d+))"
Andrew Geissler5f350902021-07-23 13:09:54 -040026
Andrew Geissler5082cc72023-09-11 08:41:39 -040027EXTRA_OEMESON += "-Dtests=disabled -Dvapi=disabled"
28
Andrew Geissler5f350902021-07-23 13:09:54 -040029# This isn't a GNOME-style version do gnome_verdir fails. Just return the
30# version as that is how the directory is structured.
31def gnome_verdir(v):
32 return v