blob: b2fd8209d0b107ef56a5e485211837c8c0a497fb [file] [log] [blame]
Lancelot Kaod3e767d2021-02-22 16:48:42 -06001SUMMARY = "Phosphor OpenBMC Kudo CPLD Firmware Upgrade Command"
2DESCRIPTION = "Phosphor OpenBMC Kudo CPLD Firmware Upgrade Comman Daemon"
3
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
7
8inherit systemd
9inherit obmc-phosphor-systemd
10
11DEPENDS += "systemd"
12DEPENDS += "phosphor-ipmi-flash"
13RDEPENDS_${PN} += "libsystemd"
14RDEPENDS_${PN} += "bash"
15
16FILES_${PN} += "${datadir}/phosphor-ipmi-flash/config-bmccpld.json"
17FILES_${PN} += "${datadir}/phosphor-ipmi-flash/config-mbcpld.json"
18
19SRC_URI_append_kudo = " \
20 file://phosphor-ipmi-flash-bmccpld-update.service \
21 file://phosphor-ipmi-flash-mbcpld-update.service \
22 file://config-bmccpld.json \
23 file://config-mbcpld.json \
24 "
25
26SYSTEMD_PACKAGES = "${PN}"
27SYSTEMD_SERVICE_${PN}_append_kudo = " \
28 phosphor-ipmi-flash-bmccpld-update.service \
29 phosphor-ipmi-flash-mbcpld-update.service \
30 "
31
32do_install () {
33 install -d ${D}${datadir}/phosphor-ipmi-flash
34 install -m 0644 ${WORKDIR}/config-bmccpld.json ${D}${datadir}/phosphor-ipmi-flash
35 install -m 0644 ${WORKDIR}/config-mbcpld.json ${D}${datadir}/phosphor-ipmi-flash
36 install -d ${D}${systemd_system_unitdir}
37 install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-bmccpld-update.service ${D}${systemd_system_unitdir}
38 install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-mbcpld-update.service ${D}${systemd_system_unitdir}
39}