blob: 4a5a05060c92d557904c2cc5b3c4146f8f69466b [file] [log] [blame]
Brad Bishop2f973922019-11-11 07:58:48 -05001SUMMARY = "A client-side C library implementing the SSH2 protocol"
2HOMEPAGE = "http://www.libssh2.org/"
3SECTION = "libs"
4
5DEPENDS = "zlib"
6
7LICENSE = "BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://COPYING;md5=c5cf34fc0acb44b082ef50ef5e4354ca"
9
Brad Bishop996bc452019-12-02 13:05:15 -050010SRC_URI = "http://www.libssh2.org/download/${BP}.tar.gz \
11 file://CVE-2019-17498.patch \
Andrew Geisslera2681d92020-10-16 10:17:07 -050012 file://run-ptest \
Brad Bishop996bc452019-12-02 13:05:15 -050013"
Andrew Geissler72956ed2021-01-08 16:11:14 -060014
15SRC_URI_append_ptest = " file://0001-Don-t-let-host-enviroment-to-decide-if-a-test-is-bui.patch"
16
Brad Bishop2f973922019-11-11 07:58:48 -050017SRC_URI[md5sum] = "1beefafe8963982adc84b408b2959927"
18SRC_URI[sha256sum] = "d5fb8bd563305fd1074dda90bd053fb2d29fc4bce048d182f96eaa466dfadafd"
19
Andrew Geisslera2681d92020-10-16 10:17:07 -050020inherit autotools pkgconfig ptest
Brad Bishop2f973922019-11-11 07:58:48 -050021
22EXTRA_OECONF += "\
23 --with-libz \
24 --with-libz-prefix=${STAGING_LIBDIR} \
25 "
26
27# only one of openssl and gcrypt could be set
28PACKAGECONFIG ??= "openssl"
29PACKAGECONFIG[openssl] = "--with-crypto=openssl --with-libssl-prefix=${STAGING_LIBDIR}, , openssl"
30PACKAGECONFIG[gcrypt] = "--with-crypto=libgcrypt --with-libgcrypt-prefix=${STAGING_EXECPREFIXDIR}, , libgcrypt"
31
Brad Bishope42b3e32020-01-15 22:08:42 -050032BBCLASSEXTEND = "native nativesdk"
Andrew Geisslera2681d92020-10-16 10:17:07 -050033
Andrew Geissler4b7c1152020-11-30 19:55:29 -060034# required for ptest on documentation
Andrew Geissler72956ed2021-01-08 16:11:14 -060035RDEPENDS_${PN}-ptest = "man-db openssh"
Andrew Geissler4b7c1152020-11-30 19:55:29 -060036RDEPENDS_${PN}-ptest_append_libc-glibc = " locale-base-en-us"
Andrew Geisslera2681d92020-10-16 10:17:07 -050037
38do_compile_ptest() {
39 sed -i "/\$(MAKE) \$(AM_MAKEFLAGS) check-TESTS/d" tests/Makefile
40 oe_runmake check
41}
42
43do_install_ptest() {
44 install -d ${D}${PTEST_PATH}/tests
Andrew Geisslera2681d92020-10-16 10:17:07 -050045 install -m 0755 ${S}/test-driver ${D}${PTEST_PATH}/
Andrew Geissler72956ed2021-01-08 16:11:14 -060046 cp -rf ${B}/tests/.libs/* ${D}${PTEST_PATH}/tests/
47 cp -rf ${S}/tests/mansyntax.sh ${D}${PTEST_PATH}/tests/
48 cp -rf ${S}/tests/ssh2.sh ${D}${PTEST_PATH}/tests/
49 cp -rf ${S}/tests/etc ${D}${PTEST_PATH}/tests/
Andrew Geissler4b7c1152020-11-30 19:55:29 -060050 mkdir -p ${D}${PTEST_PATH}/docs
51 cp -r ${S}/docs/* ${D}${PTEST_PATH}/docs/
Andrew Geisslera2681d92020-10-16 10:17:07 -050052}