Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "interface to seccomp filtering mechanism" |
| 2 | DESCRIPTION = "The libseccomp library provides and easy to use, platform independent,interface to the Linux Kernel's syscall filtering mechanism: seccomp." |
| 3 | HOMEPAGE = "https://github.com/seccomp/libseccomp" |
| 4 | SECTION = "security" |
| 5 | LICENSE = "LGPL-2.1" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;beginline=0;endline=1;md5=8eac08d22113880357ceb8e7c37f989f" |
| 7 | |
| 8 | DEPENDS += "gperf-native" |
| 9 | |
| 10 | SRCREV = "57357d2741a3b3d3e8425889a6b79a130e0fa2f3" |
| 11 | |
| 12 | SRC_URI = "git://github.com/seccomp/libseccomp.git;branch=release-2.5;protocol=https \ |
| 13 | file://run-ptest \ |
| 14 | " |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | inherit autotools-brokensep pkgconfig ptest features_check |
| 19 | |
| 20 | REQUIRED_DISTRO_FEATURES = "seccomp" |
| 21 | |
| 22 | PACKAGECONFIG ??= "" |
| 23 | PACKAGECONFIG[python] = "--enable-python, --disable-python, python3" |
| 24 | |
| 25 | DISABLE_STATIC = "" |
| 26 | |
| 27 | do_compile_ptest() { |
| 28 | oe_runmake -C tests check-build |
| 29 | } |
| 30 | |
| 31 | do_install_ptest() { |
| 32 | install -d ${D}${PTEST_PATH}/tests |
| 33 | install -d ${D}${PTEST_PATH}/tools |
| 34 | for file in $(find tests/* -executable -type f); do |
| 35 | install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests |
| 36 | done |
| 37 | for file in $(find tests/*.tests -type f); do |
| 38 | install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests |
| 39 | done |
| 40 | for file in $(find tools/* -executable -type f); do |
| 41 | install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools |
| 42 | done |
| 43 | # Overwrite libtool wrappers with real executables |
| 44 | for file in $(find tools/.libs/* -executable -type f); do |
| 45 | install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools |
| 46 | done |
| 47 | } |
| 48 | |
| 49 | FILES:${PN} = "${bindir} ${libdir}/${BPN}.so*" |
| 50 | FILES:${PN}-dbg += "${libdir}/${PN}/tests/.debug/* ${libdir}/${PN}/tools/.debug" |
| 51 | |
| 52 | RDEPENDS:${PN}-ptest = "coreutils bash" |
| 53 | |
| 54 | PV = "2.5.3" |