Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | # |
2 | # Copyright OpenEmbedded Contributors | ||||
3 | # | ||||
4 | # SPDX-License-Identifier: MIT | ||||
5 | # | ||||
6 | |||||
7 | IMAGE_PREPROCESS_COMMAND:append = " combine_dbg_image; " | ||||
8 | |||||
9 | combine_dbg_image () { | ||||
10 | if [ "${IMAGE_GEN_DEBUGFS}" = "1" -a -e ${IMAGE_ROOTFS}-dbg ]; then | ||||
11 | # copy target files into -dbg rootfs, so it can be used for | ||||
12 | # debug purposes directly | ||||
13 | tar -C ${IMAGE_ROOTFS} -cf - . | tar -C ${IMAGE_ROOTFS}-dbg -xf - | ||||
14 | fi | ||||
15 | } |