Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | # |
| 2 | # Copyright OpenEmbedded Contributors |
| 3 | # |
| 4 | # SPDX-License-Identifier: MIT |
| 5 | # |
| 6 | |
| 7 | #This function create a version information file |
| 8 | toolchain_create_sdk_version () { |
| 9 | local versionfile=$1 |
| 10 | rm -f $versionfile |
| 11 | touch $versionfile |
| 12 | echo 'Distro: ${DISTRO}' >> $versionfile |
| 13 | echo 'Distro Version: ${DISTRO_VERSION}' >> $versionfile |
| 14 | echo 'Metadata Revision: ${METADATA_REVISION}' >> $versionfile |
| 15 | echo 'Timestamp: ${DATETIME}' >> $versionfile |
| 16 | } |
| 17 | toolchain_create_sdk_version[vardepsexclude] = "DATETIME" |