Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | require boost-${PV}.inc |
2 | |||||
3 | SUMMARY = "Portable Boost.Jam build tool for boost" | ||||
4 | SECTION = "devel" | ||||
5 | |||||
6 | inherit native | ||||
7 | |||||
8 | SRC_URI += "file://bjam-native-build-bjam.debug.patch \ | ||||
9 | file://0001-Fix-a-strange-assert-typo-how-was-this-released-with.patch" | ||||
10 | |||||
11 | do_compile() { | ||||
12 | ./bootstrap.sh --with-toolset=gcc | ||||
13 | } | ||||
14 | |||||
15 | do_install() { | ||||
16 | install -d ${D}${bindir}/ | ||||
17 | # install unstripped version for bjam | ||||
18 | install -c -m 755 bjam.debug ${D}${bindir}/bjam | ||||
19 | } |