Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 1 | SUMMARY = "Framebuffer image and doc viewer tools" |
| 2 | DESCRIPTION = "The fbida project contains a few applications for viewing and editing images, \ |
| 3 | with the main focus being photos." |
| 4 | HOMEPAGE = "https://www.kraxel.org/blog/linux/fbida/" |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 5 | SECTION = "utils" |
| 6 | |
| 7 | LICENSE = "GPL-2.0-only" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=e8feb78a32950a909621bbb51f634b39" |
| 9 | |
| 10 | DEPENDS = "virtual/libiconv jpeg fontconfig freetype libexif libdrm pixman udev libinput cairo" |
| 11 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 12 | PV = "2.14+git" |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 13 | SRC_URI = "git://github.com/kraxel/fbida;protocol=https;branch=master \ |
| 14 | file://fix-preprocessor.patch \ |
| 15 | file://support-jpeg-turbo.patch \ |
| 16 | file://fbida-gcc10.patch \ |
| 17 | file://0001-meson.build-install-fbgs-shell-script.patch \ |
| 18 | file://0002-meson.build-add-features-options-for-png-gif-tiff-we.patch \ |
| 19 | file://0003-meson.build-do-not-require-xkbcommon.patch \ |
| 20 | file://0001-meson.build-make-fbpdf-build-optional.patch \ |
| 21 | file://0001-fbida-Include-missing-sys-types.h.patch \ |
| 22 | " |
| 23 | SRCREV = "eb769e3d7f4a073d4c37ed524ebd5017c6a578f5" |
| 24 | S = "${WORKDIR}/git" |
| 25 | |
| 26 | inherit meson pkgconfig features_check |
| 27 | |
| 28 | # Depends on libepoxy |
| 29 | REQUIRED_DISTRO_FEATURES = "opengl" |
| 30 | |
| 31 | PACKAGECONFIG ??= "gif png pdf" |
| 32 | PACKAGECONFIG[gif] = "-Dgif=enabled,-Dgif=disabled,giflib" |
| 33 | PACKAGECONFIG[png] = "-Dpng=enabled,-Dpng=disabled,libpng" |
| 34 | PACKAGECONFIG[tiff] = "-Dtiff=enabled,-Dtiff=disabled,tiff" |
| 35 | PACKAGECONFIG[motif] = "-Dmotif=enabled,-Dmotif=disabled,libx11 libxext libxpm libxt openmotif" |
| 36 | PACKAGECONFIG[webp] = "-Dwebp=enabled,-Dwebp=disabled,libwebp" |
| 37 | PACKAGECONFIG[pdf] = "-Dpdf=enabled,-Dpdf=disabled,poppler libepoxy" |
| 38 | |
| 39 | CFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', '-DEGL_NO_X11=1', d)}" |
| 40 | |
| 41 | RDEPENDS:${PN} = "ttf-dejavu-sans-mono" |