Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Test::Warnings - Test for warnings and the lack of them" |
| 2 | DESCRIPTION = "If you've ever tried to use Test::NoWarnings to confirm there are no \ |
| 3 | warnings generated by your tests, combined with the convenience of \ |
| 4 | \\"done_testing\\" to not have to declare a test count, you'll have discovered \ |
| 5 | that these two features do not play well together, as the test count will \ |
| 6 | be calculated *before* the warnings test is run, resulting in a TAP error. \ |
| 7 | (See "examples/test_nowarnings.pl" in this distribution for a \ |
| 8 | demonstration.)" |
| 9 | HOMEPAGE = "https://github.com/karenetheridge/Test-Warnings" |
| 10 | BUGTRACKER = "https://rt.cpan.org/Public/Dist/Display.html?Name=Test-Warnings" |
| 11 | SECTION = "libs" |
Patrick Williams | f52e3dd | 2024-01-26 13:04:43 -0600 | [diff] [blame] | 12 | LICENSE = "Artistic-1.0-Perl | GPL-1.0-or-later" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 13 | |
Patrick Williams | f52e3dd | 2024-01-26 13:04:43 -0600 | [diff] [blame] | 14 | LIC_FILES_CHKSUM = "file://LICENCE;md5=f98106ac3cc05d9cbebcdb8fbf7b7815" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 15 | |
| 16 | SRC_URI = "${CPAN_MIRROR}/authors/id/E/ET/ETHER/Test-Warnings-${PV}.tar.gz" |
| 17 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 18 | SRC_URI[sha256sum] = "b9c375719f2c61c5f97aa5ee6cf4c901a972347c415969379b0b51f67c48bbcb" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 19 | |
| 20 | S = "${WORKDIR}/Test-Warnings-${PV}" |
| 21 | |
| 22 | inherit cpan ptest-perl |
| 23 | |
| 24 | RDEPENDS:${PN} += "\ |
| 25 | perl-module-test-builder \ |
| 26 | " |
| 27 | |
| 28 | # Many hidden dependencies and mysterious failures occur without full perl-modules |
| 29 | RDEPENDS:${PN}-ptest += "perl-modules" |
| 30 | |
| 31 | do_install_ptest_perl:append () { |
| 32 | cp -r ${B}/t/lib ${D}${PTEST_PATH}/t/ |
| 33 | chown -R root:root ${D}${PTEST_PATH}/t/lib |
| 34 | } |
| 35 | |
| 36 | BBCLASSEXTEND = "native nativesdk" |