Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 1 | SUMMARY = "XML::Parser - A perl module for parsing XML documents" |
| 2 | HOMEPAGE = "https://libexpat.github.io/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "Artistic-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4342f85bf14a1fdd6a751573f1e61c03" |
| 6 | |
| 7 | DEPENDS += "expat" |
| 8 | |
| 9 | SRC_URI = "${CPAN_MIRROR}/modules/by-module/XML/XML-Parser-${PV}.tar.gz \ |
| 10 | file://0001-Makefile.PL-make-check_lib-cross-friendly.patch \ |
| 11 | " |
| 12 | |
| 13 | SRC_URI[sha256sum] = "ad4aae643ec784f489b956abe952432871a622d4e2b5c619e8855accbfc4d1d8" |
| 14 | |
| 15 | S = "${WORKDIR}/XML-Parser-${PV}" |
| 16 | |
| 17 | EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR} CC='${CC}' LD='${CCLD}' FULL_AR='${AR}'" |
| 18 | |
| 19 | inherit cpan pkgconfig ptest-perl |
| 20 | |
| 21 | do_compile() { |
| 22 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" |
| 23 | cpan_do_compile |
| 24 | } |
| 25 | |
| 26 | do_compile:class-native() { |
| 27 | cpan_do_compile |
| 28 | } |
| 29 | |
| 30 | do_install_ptest() { |
| 31 | sed -i -e "s:/usr/local/bin/perl:/usr/bin/perl:g" ${B}/samples/xmlstats |
| 32 | sed -i -e "s:/usr/local/bin/perl:/usr/bin/perl:g" ${B}/samples/xmlfilter |
| 33 | sed -i -e "s:/usr/local/bin/perl:/usr/bin/perl:g" ${B}/samples/xmlcomments |
| 34 | sed -i -e "s:/usr/local/bin/perl:/usr/bin/perl:g" ${B}/samples/canonical |
| 35 | cp -r ${B}/samples ${D}${PTEST_PATH} |
| 36 | chown -R root:root ${D}${PTEST_PATH}/samples |
| 37 | } |
| 38 | |
| 39 | RDEPENDS:${PN} += "perl-module-carp perl-module-file-spec" |
| 40 | RDEPENDS:${PN}-ptest += "perl-module-filehandle perl-module-if perl-module-test perl-module-test-more" |
| 41 | |
| 42 | BBCLASSEXTEND="native nativesdk" |