Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "A library to abstract stream I/O like serial port, TCP, telnet, etc" |
| 2 | HOMEPAGE = "https://github.com/cminyard/gensio" |
| 3 | LICENSE = "GPL-2.0-only & LGPL-2.1-only" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a0fd36908af843bcee10cb6dfc47fa67 \ |
| 5 | file://COPYING;md5=bae3019b4c6dc4138c217864bd04331f \ |
| 6 | " |
| 7 | |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 8 | SRCREV = "a96805508864a46b8a7977aaf131c28742cddd11" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 9 | |
| 10 | SRC_URI = "git://github.com/cminyard/gensio;protocol=https;branch=master" |
| 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | inherit autotools |
| 15 | |
| 16 | PACKAGECONFIG ??= "openssl tcp-wrappers" |
| 17 | |
| 18 | PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_HOST}${prefix},--without-openssl, openssl" |
| 19 | PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,--without-tcp-wrappers, tcp-wrappers" |
| 20 | PACKAGECONFIG[swig] = "--with-swig,--without-swig, swig" |
| 21 | |
| 22 | EXTRA_OECONF = "--without-python" |
| 23 | |
| 24 | RDEPENDS:${PN} += "bash" |
Andrew Geissler | 028142b | 2023-05-05 11:29:21 -0500 | [diff] [blame] | 25 | |
| 26 | FILES:${PN}-staticdev += "${libexecdir}/gensio/${PV}/libgensio_*.a" |