Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "The Geolocation Service" |
| 2 | DESCRIPTION = "Geoclue is a D-Bus service that provides location information. \ |
| 3 | The primary goal of the Geoclue project is to make creating location-aware applications \ |
| 4 | as simple as possible, while the secondary goal is to ensure that no application \ |
| 5 | can access location information without explicit permission from user." |
| 6 | LICENSE = "GPL-2.0-or-later" |
| 7 | SECTION = "console/network" |
| 8 | |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=bdfdd4986a0853eb84eeba85f9d0c4d6" |
| 10 | |
| 11 | DEPENDS = "glib-2.0 dbus json-glib libsoup-3.0 intltool-native" |
| 12 | |
| 13 | inherit meson pkgconfig gtk-doc gobject-introspection vala useradd |
| 14 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 15 | SRCREV = "bbfb6289dedb88cb8155d9f6868787d5432e1f90" |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 16 | SRC_URI = "git://gitlab.freedesktop.org/geoclue/geoclue.git;protocol=https;nobranch=1 \ |
| 17 | file://0001-libgeoclue-don-t-try-to-use-g-ir-scanner-when-intros.patch \ |
| 18 | " |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | |
| 22 | # Without this line, package is declared a library and named libgeoclue* |
| 23 | AUTO_LIBNAME_PKGS = "" |
| 24 | |
| 25 | PACKAGECONFIG ??= "3g modem-gps cdma nmea lib" |
| 26 | PACKAGECONFIG[3g] = "-D3g-source=true,-D3g-source=false,modemmanager" |
| 27 | PACKAGECONFIG[modem-gps] = "-Dmodem-gps-source=true,-Dmodem-gps-source=false,modemmanager" |
| 28 | PACKAGECONFIG[cdma] = "-Dcdma-source=true,-Dcdma-source=false,modemmanager" |
| 29 | PACKAGECONFIG[nmea] = "-Dnmea-source=true,-Dnmea-source=false,avahi,avahi-daemon" |
| 30 | PACKAGECONFIG[lib] = "-Dlibgeoclue=true,-Dlibgeoclue=false,gobject-introspection" |
| 31 | |
| 32 | GTKDOC_MESON_OPTION = "gtk-doc" |
| 33 | |
| 34 | EXTRA_OEMESON += " \ |
| 35 | -Ddbus-sys-dir=${sysconfdir}/dbus-1/system.d \ |
| 36 | -Ddemo-agent=false \ |
| 37 | " |
| 38 | |
| 39 | USERADD_PACKAGES = "${PN}" |
| 40 | USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 --shell /bin/nologin polkitd" |
| 41 | |
| 42 | do_install:append() { |
| 43 | if ${@bb.utils.contains('PACKAGECONFIG', 'modem-gps', 'true', 'false', d)}; then |
| 44 | # Fix up permissions on polkit rules.d to work with rpm4 constraints |
| 45 | chmod 700 ${D}/${datadir}/polkit-1/rules.d |
| 46 | chown polkitd:root ${D}/${datadir}/polkit-1/rules.d |
| 47 | fi |
| 48 | } |
| 49 | |
| 50 | FILES:${PN} += " \ |
| 51 | ${datadir}/dbus-1/system-services \ |
| 52 | ${datadir}/polkit-1/rules.d \ |
| 53 | ${libdir} \ |
| 54 | ${systemd_unitdir} \ |
| 55 | ${prefix}/libexec \ |
| 56 | " |
| 57 | |
| 58 | FILES:${PN}-dev += " \ |
| 59 | ${datadir}/dbus-1/interfaces \ |
| 60 | ${datadir}/gir-1.0 \ |
| 61 | " |