Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | DESCRIPTION = "Very fast, header only, C++ logging library." |
| 2 | HOMEPAGE = "https://github.com/gabime/spdlog/wiki" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" |
| 5 | |
| 6 | SRCREV = "ad0e89cbfb4d0c1ce4d097e134eb7be67baebb36" |
| 7 | SRC_URI = "git://github.com/gabime/spdlog.git;protocol=https;branch=v1.x \ |
| 8 | file://0001-Do-not-use-LFS64-functions-on-linux-musl.patch \ |
| 9 | " |
| 10 | |
| 11 | DEPENDS += "fmt" |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | BBCLASSEXTEND = "native" |
| 16 | # no need to build example & tests & benchmarks on pure yocto |
| 17 | EXTRA_OECMAKE += "-DSPDLOG_INSTALL=on -DSPDLOG_BUILD_SHARED=on -DSPDLOG_BUILD_EXAMPLE=off -DSPDLOG_BUILD_TESTS=off -DSPDLOG_BUILD_BENCH=off -DSPDLOG_FMT_EXTERNAL=on" |
| 18 | |
| 19 | inherit cmake |