Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 1 | # Copyright (C) 2021 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = "execnet: rapid multi-Python deployment" |
| 5 | HOMEPAGE = "https://execnet.readthedocs.io/en/latest/" |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=772fcdaca14b378878d05c7d857e6c3e" |
| 8 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 9 | DEPENDS += "\ |
| 10 | python3-pip-native \ |
| 11 | python3-setuptools-scm-native \ |
| 12 | " |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 13 | |
| 14 | SRC_URI += "file://run-ptest \ |
| 15 | " |
| 16 | SRC_URI[sha256sum] = "8f694f3ba9cc92cab508b152dcfe322153975c29bda272e2fd7f3f00f36e47c5" |
| 17 | |
| 18 | inherit ptest pypi setuptools3 |
| 19 | |
| 20 | do_install_ptest() { |
| 21 | install -d ${D}${PTEST_PATH}/tests |
| 22 | cp -rf ${S}/testing/* ${D}${PTEST_PATH}/tests/ |
| 23 | } |
| 24 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 25 | RDEPENDS:${PN}-ptest += "\ |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 26 | python3-pytest \ |
| 27 | " |
| 28 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 29 | RDEPENDS:${PN} += "python3-core python3-crypt python3-ctypes python3-fcntl python3-io python3-shell python3-threading" |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 30 | |
| 31 | BBCLASSEXTEND = "native nativesdk" |