Brad Bishop | dec060e | 2019-09-23 08:01:31 -0400 | [diff] [blame] | 1 | SUMMARY = "A lightweight, simple-to-use, RNN wake word listener." |
| 2 | HOMEPAGE = "https://github.com/MycroftAI/mycroft-precise" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://README.md;md5=2ad29e930f3107d52d2a55728bf62116" |
| 5 | |
| 6 | SRC_URI[md5sum] = "a2434be110444192e804f4dada0ccecf" |
| 7 | SRC_URI[sha256sum] = "1a464209fb4bf0a3f5d5a428310cb2a70487a01a6bc3a960d1dda90af896b80d" |
| 8 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 9 | inherit pypi setuptools3 ptest |
| 10 | |
| 11 | SRC_URI += " \ |
| 12 | file://run-ptest \ |
| 13 | " |
| 14 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 15 | RDEPENDS:${PN}-ptest += " \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 16 | ${PYTHON_PN}-pytest \ |
| 17 | " |
| 18 | |
| 19 | do_install_ptest() { |
| 20 | install -d ${D}${PTEST_PATH}/test |
| 21 | cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/ |
| 22 | } |