Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Python binding to the Networking and Cryptography (NaCl) library" |
| 2 | DESCRIPTION = "Python binding to the Networking and Cryptography (NaCl) library" |
| 3 | HOMEPAGE = "https://github.com/pyca/pynacl" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8cc789b082b3d97e1ccc5261f8594d3f" |
| 6 | |
| 7 | SRC_URI[sha256sum] = "8ac7448f09ab85811607bdd21ec2464495ac8b7c66d146bf545b0f08fb9220ba" |
| 8 | |
| 9 | PYPI_PACKAGE = "PyNaCl" |
| 10 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 11 | inherit pypi python_setuptools_build_meta |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 12 | |
| 13 | DEPENDS += "\ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 14 | ${PYTHON_PN}-cffi-native \ |
| 15 | libsodium \ |
| 16 | " |
| 17 | |
| 18 | RDEPENDS:${PN} = "\ |
| 19 | ${PYTHON_PN}-six \ |
| 20 | ${PYTHON_PN}-cffi \ |
| 21 | libsodium \ |
| 22 | " |
| 23 | |
| 24 | do_compile:prepend() { |
| 25 | export SODIUM_INSTALL=system |
| 26 | } |
| 27 | |
| 28 | do_install:prepend() { |
| 29 | export SODIUM_INSTALL=system |
| 30 | } |