Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "The Swiss Army knife of Python web development" |
| 2 | DESCRIPTION = "\ |
| 3 | Werkzeug started as simple collection of various utilities for WSGI \ |
| 4 | applications and has become one of the most advanced WSGI utility modules. \ |
| 5 | It includes a powerful debugger, full featured request and response objects, \ |
| 6 | HTTP utilities to handle entity tags, cache control headers, HTTP dates, \ |
| 7 | cookie handling, file uploads, a powerful URL routing system and a bunch \ |
| 8 | of community contributed addon modules." |
| 9 | HOMEPAGE = "http://werkzeug.pocoo.org/" |
| 10 | LICENSE = "BSD-3-Clause" |
| 11 | LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=5dc88300786f1c214c1e9827a5229462" |
| 12 | |
| 13 | PYPI_PACKAGE = "Werkzeug" |
| 14 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "2e1ccc9417d4da358b9de6f174e3ac094391ea1d4fbef2d667865d819dfd0afe" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 16 | |
| 17 | inherit pypi setuptools3 |
| 18 | |
| 19 | CLEANBROKEN = "1" |
| 20 | |
| 21 | RDEPENDS:${PN} += " \ |
| 22 | ${PYTHON_PN}-datetime \ |
| 23 | ${PYTHON_PN}-difflib \ |
| 24 | ${PYTHON_PN}-email \ |
| 25 | ${PYTHON_PN}-html \ |
| 26 | ${PYTHON_PN}-io \ |
| 27 | ${PYTHON_PN}-json \ |
| 28 | ${PYTHON_PN}-logging \ |
| 29 | ${PYTHON_PN}-netclient \ |
| 30 | ${PYTHON_PN}-netserver \ |
| 31 | ${PYTHON_PN}-numbers \ |
| 32 | ${PYTHON_PN}-pkgutil \ |
| 33 | ${PYTHON_PN}-pprint \ |
| 34 | ${PYTHON_PN}-simplejson \ |
| 35 | ${PYTHON_PN}-threading \ |
| 36 | ${PYTHON_PN}-unixadmin \ |
| 37 | ${PYTHON_PN}-misc \ |
| 38 | ${PYTHON_PN}-profile \ |
| 39 | ${PYTHON_PN}-markupsafe \ |
| 40 | " |