blob: 63700024c2244c613352f83e7531f31db3e9f286 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "The module provides handy URL class for url parsing and changing"
2HOMEPAGE = "https://github.com/aio-libs/yarl/"
3LICENSE = "Apache-2.0"
Andrew Geissler3eeda902023-05-19 10:14:02 -05004LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
Andrew Geissler517393d2023-01-13 08:55:19 -06005
Andrew Geissler3eeda902023-05-19 10:14:02 -05006SRC_URI[sha256sum] = "04ab9d4b9f587c06d801c2abfe9317b77cdf996c65a90d5e84ecc45010823571"
Andrew Geissler517393d2023-01-13 08:55:19 -06007
8SRC_URI += "file://run-ptest"
9
10PYPI_PACKAGE = "yarl"
11
12inherit pypi ptest setuptools3
13
14RDEPENDS:${PN} = "\
15 ${PYTHON_PN}-multidict \
16 ${PYTHON_PN}-idna \
17 ${PYTHON_PN}-io \
18"
19
20RDEPENDS:${PN}-ptest += " \
21 ${PYTHON_PN}-pytest \
22"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/tests
26 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
27}