Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame^] | 1 | DESCRIPTION = "IMA/EVM control utility" |
| 2 | LICENSE = "GPL-2.0-with-OpenSSL-exception" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 4 | |
| 5 | DEPENDS += "openssl attr keyutils" |
| 6 | |
| 7 | DEPENDS:class-native += "openssl-native keyutils-native" |
| 8 | |
| 9 | SRC_URI = "https://sourceforge.net/projects/linux-ima/files/${BPN}/${BP}.tar.gz" |
| 10 | SRC_URI[sha256sum] = "fcf85b31d6292051b3679e5f17ffa7f89b6898957aad0f59aa4e9878884b27d1" |
| 11 | |
| 12 | inherit pkgconfig autotools features_check |
| 13 | |
| 14 | REQUIRED_DISTRO_FEATURES = "ima" |
| 15 | REQUIRED_DISTRO_FEATURES:class-native = "" |
| 16 | |
| 17 | EXTRA_OECONF:append:class-target = " --with-kernel-headers=${STAGING_KERNEL_BUILDDIR}" |
| 18 | |
| 19 | # blkid is called by evmctl when creating evm checksums. |
| 20 | # This is less useful when signing files on the build host, |
| 21 | # so disable it when compiling on the host. |
| 22 | RDEPENDS:${PN}:append:class-target = " util-linux-blkid libcrypto attr libattr keyutils" |
| 23 | |
| 24 | BBCLASSEXTEND = "native nativesdk" |