Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | # This recipe is for bootstrapping our go-cross from a prebuilt binary of Go from golang.org. |
| 2 | |
| 3 | SUMMARY = "Go programming language compiler (upstream binary for bootstrap)" |
| 4 | HOMEPAGE = " http://golang.org/" |
| 5 | LICENSE = "BSD-3-Clause" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707" |
| 7 | |
| 8 | PROVIDES = "go-native" |
| 9 | |
| 10 | SRC_URI = "https://dl.google.com/go/go${PV}.${BUILD_GOOS}-${BUILD_GOARCH}.tar.gz;name=go_${BUILD_GOTUPLE}" |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame^] | 11 | SRC_URI[go_linux_amd64.sha256sum] = "e54bec97a1a5d230fc2f9ad0880fcbabb5888f30ed9666eca4a91c5a32e86cbc" |
| 12 | SRC_URI[go_linux_arm64.sha256sum] = "fc4ad28d0501eaa9c9d6190de3888c9d44d8b5fb02183ce4ae93713f67b8a35b" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 13 | |
| 14 | UPSTREAM_CHECK_URI = "https://golang.org/dl/" |
| 15 | UPSTREAM_CHECK_REGEX = "go(?P<pver>\d+(\.\d+)+)\.linux" |
| 16 | |
| 17 | S = "${WORKDIR}/go" |
| 18 | |
| 19 | inherit goarch native |
| 20 | |
| 21 | do_compile() { |
| 22 | : |
| 23 | } |
| 24 | |
| 25 | make_wrapper() { |
| 26 | rm -f ${D}${bindir}/$1 |
| 27 | cat <<END >${D}${bindir}/$1 |
| 28 | #!/bin/bash |
| 29 | here=\`dirname \$0\` |
| 30 | export GOROOT="${GOROOT:-\`readlink -f \$here/../lib/go\`}" |
| 31 | \$here/../lib/go/bin/$1 "\$@" |
| 32 | END |
| 33 | chmod +x ${D}${bindir}/$1 |
| 34 | } |
| 35 | |
| 36 | do_install() { |
| 37 | find ${S} -depth -type d -name testdata -exec rm -rf {} + |
| 38 | |
| 39 | install -d ${D}${bindir} ${D}${libdir}/go |
| 40 | cp --preserve=mode,timestamps -R ${S}/ ${D}${libdir}/ |
| 41 | |
| 42 | for f in ${S}/bin/* |
| 43 | do |
| 44 | make_wrapper `basename $f` |
| 45 | done |
| 46 | } |