Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 1 | SUMMARY = "in-depth comparison of files, archives, and directories" |
| 2 | DESCRIPTION = "Tries to get to the bottom of what makes files or directories \ |
| 3 | different. It will recursively unpack archives of many kinds and transform \ |
| 4 | various binary formats into more human-readable form to compare them. \ |
| 5 | It can compare two tarballs, ISO images, or PDF just as easily." |
| 6 | HOMEPAGE = "https://diffoscope.org/" |
| 7 | BUGTRACKER = "https://salsa.debian.org/reproducible-builds/diffoscope/-/issues" |
| 8 | LICENSE = "GPL-3.0+" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 10 | |
| 11 | PYPI_PACKAGE = "diffoscope" |
| 12 | |
| 13 | inherit pypi setuptools3 |
| 14 | |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "a295024acf713c58693c152f9a43fae268c08078f60ba502a7947b7840ece5d7" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 16 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 17 | RDEPENDS:${PN} += "binutils vim squashfs-tools python3-libarchive-c python3-magic python3-rpm" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 18 | |
| 19 | # Dependencies don't build for musl |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 20 | COMPATIBLE_HOST:libc-musl = 'null' |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 21 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 22 | do_install:append:class-native() { |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 23 | create_wrapper ${D}${bindir}/diffoscope \ |
| 24 | MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc \ |
| 25 | RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \ |
Andrew Geissler | c926e17 | 2021-05-07 16:11:35 -0500 | [diff] [blame] | 26 | LD_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE} \ |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 27 | RPM_ETCCONFIGDIR=${STAGING_DIR_NATIVE} |
| 28 | } |
| 29 | |
| 30 | BBCLASSEXTEND = "native" |